Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27226 - [nvidia] X does not start with 290

Attached to Project: Arch Linux
Opened by João Vieira (Vieira) - Tuesday, 22 November 2011, 17:03 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 15 February 2012, 10:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
After upgrading nvidia and nvidia-utils to 290 X does not start anymore.

Additional info:
* nvidia-290 (and everything up to date)
* log says "no usable screen configurations".
* graphics card is nvidia 7300go

Steps to reproduce:
* sudo pacman -Syu (as of today, 2011-11-22)
* reboot
* X won't start.
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 15 February 2012, 10:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  nvidia 295.20
Comment by João Vieira (Vieira) - Tuesday, 22 November 2011, 17:04 GMT
I didn't change the xorg.conf file but I'll attach it anyway, just in case.
Comment by Ionut Biru (wonder) - Tuesday, 22 November 2011, 17:49 GMT
paste /var/log/Xorg.0.log and dmesg output
Comment by Jelle van der Waa (jelly) - Tuesday, 22 November 2011, 17:55 GMT
Paste the full error log please, from /var/log/X11/
Comment by João Vieira (Vieira) - Tuesday, 22 November 2011, 18:12 GMT
Here is the log, as requested.
Comment by Ionut Biru (wonder) - Tuesday, 22 November 2011, 18:15 GMT
seems like it doesn't find any display connected to the card.

report this bug in http://www.nvnews.net/vbulletin/forumdisplay.php?f=14
Comment by João Vieira (Vieira) - Tuesday, 22 November 2011, 18:32 GMT
Ok, done.
http://www.nvnews.net/vbulletin/showthread.php?p=2504310

Is there anything else I can do? (I downgraded to 280 which also forced me to downgrade kernel to 3.0 and xorg-server to 1.10 and it's working fine for now... any better alternative?)
Comment by Ionut Biru (wonder) - Tuesday, 22 November 2011, 18:38 GMT
what you need more is to attach in that thread the tarball created by nvidia-bug-report.sh
Comment by João Vieira (Vieira) - Tuesday, 22 November 2011, 19:01 GMT
If there is anything else I can do please let me know.
Comment by Cosimo Sacco (thecellarguardian) - Tuesday, 22 November 2011, 20:58 GMT
Same problem here, I downgraded to 285.
Comment by Isidoro-Erich del Cueto Lopez (iedcl) - Wednesday, 23 November 2011, 22:18 GMT
Same problem here.
I had to do a forced (to keep linux>=3.1) downgrade to 285.
Now everything works fine for me.

Edit:
On a x86_64 machine with similar graca (Geforce 7600...) everthing worked fine with 290.10.
Problems seem to affect only x86 machines (buggy 32bit nvidia module??).

But I agree with [wonder] - it´s a nvidia problem and bug reports should go there.

Comment by solsTiCe (zebul666) - Thursday, 24 November 2011, 10:48 GMT
with a geforce 8300 GS, I "just" have 30 seconds during which I have a black screen with a mouse cursor and after that it's ok. But every time something is related to X or graphics it freezes another time for 30s. just launching firefox for example cause that.

https://gist.github.com/1391078
I use no xorg.conf

I had to switch back to the 285 version too
Comment by Ionut Biru (wonder) - Thursday, 24 November 2011, 10:51 GMT
any problem that you guys might have with nvidia, forward to them. this is not the right place.
Comment by solsTiCe (zebul666) - Thursday, 24 November 2011, 13:18 GMT Comment by YP (knedlyk) - Friday, 25 November 2011, 09:46 GMT
I have the same problem as Vieira has. Downgraded to 285, works fine.
Comment by Ionut Biru (wonder) - Friday, 25 November 2011, 10:06 GMT
@solstice, look where i suggested to report the issue. you did it in the wrong place
Comment by YP (knedlyk) - Tuesday, 06 December 2011, 16:30 GMT
I think I found a solution. Try to add vmalloc=256M into kernel string in grub. Looks like standard 16M is not enough for the normal work. It is temporal workaround, probably you can change this parameter in BIOS settings.
Comment by Ionut Biru (wonder) - Tuesday, 06 December 2011, 16:35 GMT
@YP your problem is not related to this bug.
Comment by cyberesprit (cyberesprit) - Friday, 30 December 2011, 11:50 GMT
Same problem with Geforce GO 7600 on laptop .. new net install, no xorg.conf
And no package 285 version for downgrade in /var/cache/pacman/pkg
Comment by Cosimo Sacco (thecellarguardian) - Friday, 30 December 2011, 12:14 GMT
@cyberesprit I checked the out of date mirrors but even the most outdated has the 290 packages. I have the old packages (nvidia and nvidia-utils ver. 285), just tell me how and I will send them to you.
Comment by Ionut Biru (wonder) - Friday, 30 December 2011, 12:52 GMT
nvidia released a new beta version. You should try it.
Comment by cyberesprit (cyberesprit) - Friday, 30 December 2011, 15:55 GMT
@Cosimo Sacco: Thanks but it's okay with NOUVEAU driver and it's okay too with the beta proprietary driver 295.09 (nvidia-beta + nvidia-utils-beta)
@Ionut Biru: Thanks, it's ok ! (The NOUVEAU driver is slow at certains moments)
Comment by Cosimo Sacco (thecellarguardian) - Friday, 30 December 2011, 21:23 GMT
@cyberesprit I'm glad to read this, I can't wait for the new drivers to enter the extra repository!
Comment by Ionut Biru (wonder) - Wednesday, 15 February 2012, 09:35 GMT
i think this problem is fixed in 295.20

Loading...