Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#27214 - [pacman] Can't upgrade pacman when gcc-multilib is installed

Attached to Project: Pacman
Opened by Marti (intgr) - Monday, 21 November 2011, 18:57 GMT
Last edited by Allan McRae (Allan) - Sunday, 22 April 2012, 09:42 GMT
Task Type Bug Report
Category Backend/Core
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity High
Priority Normal
Reported Version 4.0.0
Due in Version 4.0.3
Due Date Undecided
Percent Complete 100%
Votes 43
Private No

Details

Description: When I tried to upgrade pacman to 4.0.1 today, it told me it needs to install gcc-libs and uninstall gcc-multilib. But that fails since gcc-multilib depends on that package. This shouldn't happen, right?

The workaround is to reinstall normal gcc manually (sudo pacman -S gcc-libs gcc), then upgrade pacman, then reinstall gcc-multilib.

Steps to reproduce:
1. Downgrade to pacman 4.0.0-2
2. Install gcc-libs-multilib

:: The following packages should be upgraded first :
pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n]

resolving dependencies...
looking for inter-conflicts...
:: gcc-libs and gcc-libs-multilib are in conflict. Remove gcc-libs-multilib? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc-multilib: requires gcc-libs-multilib=4.6.2-1
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 22 April 2012, 09:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fix is in pacman-4.0.3.
Comment by Justin Gottula (jgottula) - Tuesday, 22 November 2011, 07:56 GMT
I recently encountered the same dependency problem upon updating.

Dan's workaround worked for me as well, although I had an additional package with a gcc-libs-multilib dependency that I had to uninstall temporarily.
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 22 November 2011, 08:41 GMT
Same issue here

:: The following packages should be upgraded first :
pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
:: gcc-libs and gcc-libs-multilib are in conflict. Remove gcc-libs-multilib? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gcc-libs and gcc-libs-multilib are in conflict
Comment by Dan McGee (toofishes) - Tuesday, 22 November 2011, 09:27 GMT
The "same issue" comments don't help. Please don't leave them. Thanks.
Comment by John Lindgren (jlindgren) - Wednesday, 04 January 2012, 17:24 GMT
A simpler workaround worked for me. I simply updated pacman alone ("pacman -Sy pacman") before running "pacman -Syu". The gcc conflict only seems to apply to the automatic updating of pacman before other packages.
Comment by Baptiste (zorun) - Tuesday, 24 January 2012, 19:33 GMT
As jlindgren noted, it looks like a more general issue with pacman: this silly conflict happens as soon as there is a package in SyncFirst that wants to get updated first.

I don't know if it's fixed already (I've encountered the bug today with pacman 4.0.1)
Comment by Keshav Amburay (the.ridikulus.rat) - Tuesday, 14 February 2012, 14:19 GMT
I think what jlindgren's mentioned is workaround, not a solution. This bug occurs for all the packages defined in SyncFirst in pacman.conf (not just pacman).
Comment by Dan McGee (toofishes) - Tuesday, 14 February 2012, 14:44 GMT
Stop leaving "ME TOO" comments. They are 0% helpful, and I've said this already if people even bothered to read all the comments. I'm deleting them all.
Comment by Filip Szczepański (FreeFull) - Friday, 17 February 2012, 09:15 GMT
An easier workaround is to do
pacman -S pacman
Comment by Clemens Buchacher (drizzd) - Sunday, 04 March 2012, 14:17 GMT
None of the previously mentioned workarounds worked for me. Pacman was already up-to-date, and pacman -S gcc-libs gcc gives me:

:: gcc-libs and gcc-libs-multilib are in conflict. Remove gcc-libs-multilib? [y/N] y
:: gcc and gcc-multilib are in conflict. Remove gcc-multilib? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: gcc-fortran: requires gcc=4.6.2-7
:: libtool-multilib: requires gcc-multilib=4.6.2

I am not sure exactly why, but "pacman -S gcc-fortran libtool" succeeded, and now pacman -Su manages to satisfy all dependencies.
Comment by Alexander Wagner (waquo) - Monday, 26 March 2012, 14:20 GMT
Installing libtool-multilib from the multilib-testing repository (and having libtool removed) fixed this for me.
Comment by Darshit Shah (darnir) - Saturday, 07 April 2012, 19:16 GMT
Facing same issue again with current update for 4.0.3-1 in Testing.
The given workarounds still work, however a permanent fix is required.
Comment by Krzysztof Miernik (kmiernik) - Wednesday, 11 April 2012, 13:57 GMT
This problem appears now in core.
Walkaround is:
pacman -S pacman
pacman -Syu
Comment by Allan McRae (Allan) - Sunday, 22 April 2012, 09:41 GMT
The old SyncFirst behavior is restored in pacman-4.0.3 and SyncFirst will be gone completely in 4.1.0. So once everyones upgrade to 4.0.3 is complete, this bug will be fixed.

Loading...