Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27139 - lib32-glibc breaks wine

Attached to Project: Community Packages
Opened by Ph.Philippov (br4) - Sunday, 20 November 2011, 12:25 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Sunday, 20 November 2011, 14:26 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
it doesn't matter which version of wine I use or if I have a .wine or not. I have to downgrade lib32-glibc 2.14.1-1 in order to run wine and not to get a seg. fault.

Should I provide some other info, new trace?


Steps to reproduce:
type wine or winecfg and hit 'enter'.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Sunday, 20 November 2011, 14:26 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Sunday, 20 November 2011, 12:50 GMT
is your system fully up to date?

post "paclist multilib" output
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 20 November 2011, 13:26 GMT
Can't reproduce. Trace doesn't say much either.
Comment by Ph.Philippov (br4) - Sunday, 20 November 2011, 13:34 GMT
yes the system is fully up to date.
here is the "paclist multilib".

about the trace - maybe I should recompile lib32-glibc with debug symbols
   paclist (1.9 KiB)
Comment by Ionut Biru (wonder) - Sunday, 20 November 2011, 13:36 GMT
you don't have wine from multilib?
Comment by Ph.Philippov (br4) - Sunday, 20 November 2011, 13:41 GMT
I have it. yesterday I installed this version to try if the problem was the last one.
pacman -Qi wine
Name : wine
Version : 1.3.30-1
URL : http://www.winehq.com
Licenses : LGPL
Groups : None
Provides : bin32-wine=1.3.30 wine-wow64=1.3.30
Depends On : ...
Optional Deps : ...
Required By : None
Conflicts With : bin32-wine wine-wow64
Replaces : bin32-wine
Installed Size : 223718.00 K
Packager : Florian Pritz <bluewind@xinu.at>
Architecture : x86_64
Build Date : Mon 10 Oct 2011 11:04:33 PM EEST
Install Date : Sat 19 Nov 2011 07:09:58 PM EET
Install Reason : Explicitly installed
Install Script : Yes
Description : A compatibility layer for running Windows programs
Comment by Ionut Biru (wonder) - Sunday, 20 November 2011, 13:53 GMT
we have 1.3.33 in repos
Comment by Ph.Philippov (br4) - Sunday, 20 November 2011, 14:19 GMT
if I install that(wine 1.3.33) I get
$ wine
bash: /usr/bin/wine: No such file or directory

if I have the downgraded lib32-glibc
and if I have the latest lib32-glibc 2.14.1-1 I get this

$ wine
Segmentation fault
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 20 November 2011, 14:26 GMT
Dude, get a new mirror. Your system is not sane. I'm closing this bug as it most certainly is not a packaging bug. For further help check wiki, forums, IRC or mailing lists.

Loading...