Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27131 - [acpid] please add a "sleep 1" in the rc.d-script

Attached to Project: Arch Linux
Opened by Uli (Army) - Saturday, 19 November 2011, 21:28 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 20 November 2011, 03:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The rc.d-script doesn't have - like most, if not all others do - a "sleep 1" in the restart case. Now I get this (with a running acpid)

# rc.d restart acpid
:: Stopping acpid [DONE]
:: Starting acpid [FAIL]

# rc.d restart acpid
:: Stopping acpid [FAIL]
:: Starting acpid [DONE]

After adding the "sleep 1" like this

restart)
$0 stop
sleep 1
$0 start
;;

it looks like this

# rc.d restart acpid
:: Stopping acpid [DONE]
:: Starting acpid [DONE]

Perfect :)

Additional info:
* package version(s)
acpid 2.0.12-1
* config and/or log files etc.


Steps to reproduce:

Run "rc.d restart acpid" and you'll see, that it doesn't work. At least it doesn't work here.
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 20 November 2011, 03:21 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#26958 
Comment by Karol Błażewicz (karol) - Saturday, 19 November 2011, 21:52 GMT
Duplicate of  FS#26958 .

Loading...