Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27130 - [Eclipse] crashes on new XULrunner

Attached to Project: Arch Linux
Opened by Thor (thorflanders) - Saturday, 19 November 2011, 18:58 GMT
Last edited by Ionut Biru (wonder) - Monday, 27 February 2012, 17:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

After sysupdate, Eclipse crashes when hovering over a keyword, when the tooltip is to appear.

Additional info:
* package version(s)
eclipse 3.7.1-2
xulrunner 8.0-2
xfce 4.8

* config and/or log files etc.
from the console:

# Problematic frame:
# C [libxul.so+0xc789da] NS_UTF16ToCString_P+0x19d92

Steps to reproduce:

start Eclipse by entring it in the console (to see the crash message), take a Java source, over the mouse over a keyword (JButton, or a self-made class) anything that could/should make a tooltip pop up.

Possible workaround:
Invoke Eclipse with this command:
eclipse -vmargs -Xmx384m -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-1.9.2/
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 27 February 2012, 17:56 GMT
Reason for closing:  Works for me
Additional comments about closing:  please open a new bug if is still available in 3.7.2
Comment by Thor (thorflanders) - Saturday, 19 November 2011, 19:01 GMT
Sorry, I forgot to add the Java version in the package list:
JRE version: 7.0_01-b08

My apologies...

THor
Comment by Ionut Biru (wonder) - Saturday, 19 November 2011, 19:11 GMT
if i recall new eclipse doesn't use at all xulrunner. instead they rely on webkit
Comment by Thor (thorflanders) - Saturday, 19 November 2011, 19:32 GMT
Hmm, so, where does the line come from where it said "xulrunner"? It is possible to use this line as well

-Dorg.eclipse.swt.browser.UseWebKitGTK=true

in the ini file. But, as it is in there (did'nt change it anymore) ... I'm somewhat stumped...

Of course, I dont know if my version ( libwebkit3 1.6.1-1 ) does the trick...

I hope I'm not oozing into a re-install, Blender dies with a segmentaion fault, there's all sorts of Gnome stuff on my system I dont need (anymore) and now this... :/

Comment by Ionut Biru (wonder) - Saturday, 19 November 2011, 19:36 GMT
eclipse has libwebkit as dependency. try to move away your ~/.eclipse
Comment by Thor (thorflanders) - Saturday, 19 November 2011, 20:02 GMT
Did that, same message. Eclipse made a new folder right away (good) but still dies (bad)...thanks for the tip, even if it did'nt help...
Comment by Maxwell Draven (Ravenman) - Monday, 12 December 2011, 23:23 GMT
I upgraded the system and I have this issue, too. I'm attaching the log file.
Comment by Otto Allmendinger (OttoA) - Thursday, 09 February 2012, 10:32 GMT
Crashes with xulrunner-10.0-2 - downgrade to xulrunner-9.0.1-1 fixes the crash

Eclipse only works with libwebkit-1.2.x (http://www.eclipse.org/swt/faq.php#browserwebkitgtk). The current version in [extra] however is 1.6.3-1, so it falls back to xulrunner.
Comment by Ionut Biru (wonder) - Thursday, 09 February 2012, 10:34 GMT
just for my own curiosity, for what is used xul or webkit?

Comment by Otto Allmendinger (OttoA) - Thursday, 09 February 2012, 13:37 GMT
When using autocompletion, there is a small window rendering the javadoc, probably using html. Eclipse crashes when trying to display the window.

I just remembered that I'm using the old sun jre 6u26-1, maybe this is part of the problem. I'll test it with the current / official jre later.
Comment by Ionut Biru (wonder) - Thursday, 09 February 2012, 13:48 GMT
in the cases, it works perfectly fine here without any xul and only with libwebkit.

http://ompldr.org/vY3B2ZA
Comment by Otto Allmendinger (OttoA) - Thursday, 09 February 2012, 15:07 GMT
I just tested it with current jre7/jdk7 -openjdk, still crashes with xulrunner

with xulrunner removed, everything works fine, so the info in the eclipse faq seems to be wrong

there is an answer for this in the wiki

https://wiki.archlinux.org/index.php/Eclipse#Autocompletion_and_javadoc_render_crash

I didn't find it because I was googling for the stack trace

I'd say if libwebkit already is a dependency and eclipse only runs reliably with libwebkit, the default eclipse.ini should contain

-Dorg.eclipse.swt.browser.UseWebKitGTK=true
Comment by Jon VanAlten (vanaltj) - Thursday, 23 February 2012, 23:04 GMT
I think I am having crashes with same cause, although the segfault is in different place. Here is top of hs_err file:

# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x62919a54, pid=19442, tid=3075868352
#
# JRE version: 7.0_03-b147
# Java VM: OpenJDK Client VM (22.0-b10 mixed mode linux-x86 )
# Derivative: IcedTea7 2.1
# Distribution: Custom build (Wed Feb 15 15:35:38 UTC 2012)
# Problematic frame:
# C [UTF-16.so+0xa54] gconv+0x374
#

The -Dorg.eclipse.swt.browser.UseWebKitGTK=true workaround does not work for me, probably for same reason explained by OttoA's first comment.

What does work for me is adding -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-10.0.2/ to /usr/share/eclipse/eclipse.ini

This is with:
firefox 10.0.2-1
eclipse 3.7.1-2
jdk7-openjdk 7.b147_2.1-1

So I guess Eclipse just needs to be updated when Firefox updates, and until then I just keep manually fixing the path in the .ini

Loading...