Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27103 - [libreoffice] No LibreOffice window decorations under Kwin.

Attached to Project: Arch Linux
Opened by Ondřej Konečný (andrew9888) - Saturday, 19 November 2011, 11:38 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 06 June 2012, 05:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Andrea Scarpino (BaSh)
Stéphane Gaudreault (stephane)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

When I start LibreOffice in my KDE it has no Window decorations (titlebar and stuff) - see the attached screenshot.
When I move the window, the decorations appear temporarily (until I release the mouse button).
I use QtCurve as the window decoration as well as the main theme and libreoffice-gnome to integrate LibeOffice to my desktop (libreoffice-kde looks ugly - but does not suffer from the missing window decorations).

Additional info:

* package version(s)
libreoffice-common 3.4.4-3
libreoffice-writer 3.4.4-3
libreoffice-gnome 3.4.4-3
qtcurve-gtk2 1.8.12-1
qtcurve-kde4 1.8.9-1
kdebase-workspace 4.7.3-3

Steps to reproduce:
1) Set the GTK+2 theme to QtCurve.
2) Install libreoffice and libreoffice-gnome.
3) Run libreoffice as: OOO_FORCE_DESKTOP=gnome libreoffice
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 06 June 2012, 05:48 GMT
Reason for closing:  No response
Additional comments about closing:  2 upstream releases out since last response.
Comment by Andreas Radke (AndyRTR) - Saturday, 17 March 2012, 07:30 GMT
Please check with 3.5.1 in extra now. If it's still present look for upstream reports or report it there.
Comment by Ondřej Konečný (andrew9888) - Sunday, 18 March 2012, 13:59 GMT
Problem still present with 3.5.1. I have found these two upstream bugs that seem to be the same:

https://bugs.kde.org/show_bug.cgi?id=295176
https://bugs.kde.org/show_bug.cgi?id=291774

They're marked as 'FIXED' but I am getting these glitches anyway.
I use QtCurve for both decoration and widget style.
Comment by Andreas Radke (AndyRTR) - Sunday, 18 March 2012, 14:09 GMT
This seems to be no LibO issue but rather a KDE problem. Andrea?
Comment by Ondřej Konečný (andrew9888) - Sunday, 18 March 2012, 14:42 GMT
I have done some investigation and there are results:
1) Oxygen window decoration does NOT have this issue.
2) Smaragd decoration DOES have it.
3) QtCurve decoration has this issue, but if I use Xrender for compositing instead of OpenGl there is no problem (but the performace is poor).
Comment by Andreas Radke (AndyRTR) - Sunday, 20 May 2012, 10:41 GMT
How's LibO 3.5.3 ? If it's not solved please file a new upstream issue.

Loading...