Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#27072 - [initscripts] error in functions file

Attached to Project: Arch Linux
Opened by Mick (earnon) - Saturday, 19 November 2011, 01:26 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 20 November 2011, 03:25 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Error after load '/etc/rc.d/functions'


Additional info:
* package version(s): 2011.11.3-1


Steps to reproduce:
In a terminal, use the next command

[root@host ~]# pacman -S initscripts //accept
[root@host ~]# echo '. /etc/rc.d/functions' > /tmp/test
[root@host ~]# sh /tmp/test
/etc/rc.d/functions: line 497: syntax error near unexpected token `<'
/etc/rc.d/functions: line 497: `done < <(findmnt -runRo TARGET,FSTYPE,OPTIONS / | tac)'
=> remplace '<(findmnt' by '$(findmnt'
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 20 November 2011, 03:25 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Scripts which source /etc/rc.d/functions MUST be bash. No exceptions.
Comment by Natrio (natrio) - Saturday, 19 November 2011, 08:23 GMT
Run commands:
cd /etc/rc.d/
grep -l '#!/bin/sh' *

And fix manually your scripts, that calls /etc/rc.d/functions :)
Comment by John (aske) - Saturday, 19 November 2011, 10:50 GMT
Small "patch" fixing that typo (from the duplicate issue)
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 19 November 2011, 16:18 GMT
There is no typo: <(list) is right (Process Substitution), while $(command) is (Command Substitution) two different things. See bash manual, experiment yourself ;)

Loading...