Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26971 - [linux] sd/mmc card not detected

Attached to Project: Arch Linux
Opened by Ricardo Funke Ormieres (ricardofunke) - Thursday, 17 November 2011, 21:35 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 22 February 2012, 16:35 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


Looks like the latest kernel stop to recognize sd cards.

My internal reader seems to be recognized as shown in dmesg:

[ 7.745263] sdhci: Secure Digital Host Controller Interface driver
[ 7.745267] sdhci: Copyright(c) Pierre Ossman
[ 8.140405] sdhci-pci 0000:08:05.2: SDHCI controller found [1217:7120] (rev 2)
[ 8.140428] sdhci-pci 0000:08:05.2: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 8.140510] _regulator_get: 0000:08:05.2 supply vmmc not found, using dummy regulator
[ 8.140572] Registered led device: mmc0::
[ 8.140636] mmc0: SDHCI controller on PCI [0000:08:05.2] using DMA

lspci -k shows the reader:

08:05.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 02)
Subsystem: Dell Device 0273
Kernel driver in use: sdhci-pci
Kernel modules: sdhci-pci

But when I plug any SD card, nothing occurs, nothing in the logs too.

My notebook is a Dell Vostro 1510, and I tried to use Windows Vista and the card does not opens too, then I call Dell support and they told me to upgrade the BIOS, SD and chipset drivers, after that the card started to work again, just in Windows Vista... =(

Additional info:
* package version(s)
uname -r

* config and/or log files etc.

Steps to reproduce:

Try to open any SD card in Dell Vostro 1510 with the latest kernel from Arch Linux.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 22 February 2012, 16:35 GMT
Reason for closing:  Fixed
Comment by Sebastian (Deathcrow) - Saturday, 19 November 2011, 18:27 GMT
I can confirm this problem, since I have exactly the same issue: No messages in dmesg and no other reactions when plugging in the SD card.

My card reader is a:
"SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)"

Comment by Jelle van der Waa (jelly) - Sunday, 18 December 2011, 17:10 GMT
Please try to contact the kernel developers , they can fix this issue.
Comment by Micah Nordland (mpnordland) - Friday, 20 January 2012, 20:33 GMT
You need to add options sdhci debug_quirks=0x40 to your /etc/modprobe.d/modprobe.conf for the O2 Micro
As for the Ricoh, I don't know.