Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26938 - [evas-svn] Linker error with evas-svn

Attached to Project: Community Packages
Opened by Mak Nazečić-Andrlon (Muon) - Thursday, 17 November 2011, 13:25 GMT
Last edited by Ronald van Haren (pressh) - Wednesday, 28 December 2011, 12:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Linking with -lelementary fails because of missing symbols in Evas.

Additional info:
* evas-svn 62798-1

[muon@muon-beta ~]$ gcc etest.c -o etest `pkg-config elementary --cflags --libs`
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.2/../../../../lib/libelementary.so: undefined reference to `evas_object_freeze_events_get'
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.2/../../../../lib/libelementary.so: undefined reference to `evas_smart_objects_calculate_count_get'
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.2/../../../../lib/libelementary.so: undefined reference to `evas_object_freeze_events_set'
This task depends upon

Closed by  Ronald van Haren (pressh)
Wednesday, 28 December 2011, 12:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed with updated packages
Comment by Andrea Scarpino (BaSh) - Wednesday, 14 December 2011, 18:17 GMT
  • Field changed: Summary ([elementary-svn] Linker error with elementary-svn and evas-svn → [evas-svn] Linker error with evas-svn)
  • Field changed: Details
elementary-svn has been moved to AUR by Alexander Rødseth (trontonic)
Comment by Swift Geek (swiftgeek) - Monday, 19 December 2011, 13:29 GMT
WTF? eina-svn and evas-svn packages are out of date!
everything is fine with updated packages!
Comment by Sami B. (spider-mario) - Friday, 23 December 2011, 12:07 GMT
I can confirm that elementary builds just fine when evas is up to date (which in turn requires eina to be updated).

Loading...