Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26886 - [module-init-tools]

Attached to Project: Arch Linux
Opened by Michael (madmike_) - Monday, 14 November 2011, 15:16 GMT
Last edited by Dave Reisner (falconindy) - Tuesday, 15 November 2011, 13:02 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

#20046 is not only a feature request anymore, at least the severity increased

With the replacement of /lib/modules/`uname -r`/updates by /lib/modules/`uname -r`/extramodules
external modules won't get a preference over inline modules anymore.
To my understanding depmod uses an automatic prioritization for modules in the "updates/" directory only.
Current extra modules will need an override-statement in depmod.d/$name.conf.
A possible solution would be:

echo "search extramodules updates built-in" >> /etc/depmod.d/depmod.conf


Additional info:

* module-init-tools 3.16-2
* linux 3.1-4

Steps to reproduce:

+ put a copy of several modules in extramodules/
+ run "depmod -a"
+ test "modinfo $modulename" and see what version will be chosen

Test with _several_ files since you cannot be sure that the module chosen has been preferred because it overrides the built-in module or just because it was found first.
I noticed this issue when installing the tp_smapi kernel modules.
This task depends upon

Closed by  Dave Reisner (falconindy)
Tuesday, 15 November 2011, 13:02 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#20046 
Comment by Dave Reisner (falconindy) - Tuesday, 15 November 2011, 13:02 GMT
Please learn to create descriptive bug report titles.

Loading...