Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26878 - nawk does't provide symlink /bin/awk

Attached to Project: Arch Linux
Opened by Onni R. (lotuskip) - Sunday, 13 November 2011, 14:53 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 13 November 2011, 15:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
nawk does not create a symlink for /bin/awk, so scripts invoking 'awk' are broken when one installs nawk and removes gawk. Since nawk, according to its description, "provides awk", it should also provide the symlink.

Additional info:
* package version(s): nawk 20110810-2

Steps to reproduce:
Install nawk, remove gawk, try to invoke 'awk'.
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 13 November 2011, 15:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  removed provider for extra/nawk-20110810-3
Comment by Dave Reisner (falconindy) - Sunday, 13 November 2011, 14:56 GMT
Fair point. Better solution would be to avoid the provide -- adding the /bin/awk symlink would mean creating a conflict with gawk, and that's going to break things.

Loading...