Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26854 - [musescore] no pulseaudio support

Attached to Project: Community Packages
Opened by hamelg (hamelg) - Saturday, 12 November 2011, 00:09 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 14 December 2011, 18:18 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


portaudio provides pulseaudio support.
mscore isn't linked with libportaudio, so sound output is disabled if your sound system runs pulseaudio.
please, add it.

Additional info:
* package version(s)
musescore 1.1-2
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 14 December 2011, 18:18 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Moved to AUR
Comment by hamelg (hamelg) - Thursday, 24 November 2011, 20:05 GMT
The steps to reproduce the issue are very simple :

1. Enable pulseaudio (
2. Install mscore
3. launch mscore in a console, you will see this error :
>> init ALSA audio driver failed
>> init ALSA driver failed
4. The play button is grayed, you can't play the score
5. Go to preference panel, tab I/O => You can't choose Portaudio, the checkbox is grayed

To fix that :

1. Install community/portaudio
2. Compile mscore (configure will detect and enable libportaudio)
3. Now, in the preference panel, tab I/O, uncheck ALSA Audio, and check PortAudio
4. restart mscore

Portaudio figures in Optional Deps of musescore package, but it's useless because the library is not detected and loaded at runtime.
It's a High Severity issue for all pulseaudio users.
Could you consider my request ?