Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26815 - [xfce4-weather-plugin] has expired XOAP license key

Attached to Project: Arch Linux
Opened by SanskritFritz (SanskritFritz) - Tuesday, 08 November 2011, 23:27 GMT
Last edited by Evangelos Foutras (foutrelis) - Thursday, 15 December 2011, 21:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

extra/xfce4-weather-plugin suffers from expired XOAP license key. Another (temporary) working key is available, please see here: https://bugzilla.xfce.org/show_bug.cgi?id=8105
Until an updated version is available, maybe you could consider patching the source:
xfce4-weather-plugin/src/xfce4-weather-plugin-0.7.4/panel-plugin/weather.h
#define PARTNER_ID "1003666583"
#define LICENSE_KEY "4128909340a9b2fc"
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Thursday, 15 December 2011, 21:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  The license key we originally switched to still works for me. :\
Comment by Evangelos Foutras (foutrelis) - Wednesday, 09 November 2011, 18:07 GMT
Thanks for the heads up; I had seen that bug report, but not Dan's response.
Comment by Cian McGovern (cian1500ww) - Wednesday, 14 December 2011, 15:09 GMT
  • Field changed: Percent Complete (100% → 0%)
Licence key is invalid again
Comment by Cian McGovern (cian1500ww) - Wednesday, 14 December 2011, 15:13 GMT
The following is working for me:
PARTNER_ID "10177068"
LICENSE_KEY "d266a4896754ce199c27384b44ef5662"

Those are my licence keys, feel free to use them, they'll probably expire as well as I don't have a subscription.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 14 December 2011, 15:19 GMT
Use Wireshark to capture the URL that gets called when you right click the applet and select "Refresh".

For me it's calling [1] which does not return any errors.

tl;dr: Cannot reproduce, please provide more information.

[1] http://xoap.weather.com/weather/local/GRXX0004?cc=*&dayf=5&unit=m&link=xoap&prod=xoap&par=1003666583&key=4128909340a9b2fc
Comment by Cian McGovern (cian1500ww) - Wednesday, 14 December 2011, 15:39 GMT
I think there's a difference in the licence keys.

Searching for my location returns nothing but searching for the same location using the keys I've posted above returns results.

Maybe the licence key that is being used in the repo doesn't have the same location coverage??

Also, my requests are going to a different url with the new licence keys: http://api.yr.no/weatherapi/locationforecastlts/1.1/?lat=53.990833;lon=-8.063611
Comment by Evangelos Foutras (foutrelis) - Wednesday, 14 December 2011, 16:00 GMT
Are you sure you're using the package from [extra] (xfce4-weather-plugin 0.7.4-2) and not xfce4-weather-plugin-git [1]? :D

The switch to the api.yr.no server appears only in the Git repo [2] and is not included in the most recent release (0.7.4).

[1] https://aur.archlinux.org/packages.php?ID=36485
[2] http://git.xfce.org/panel-plugins/xfce4-weather-plugin/commit/?id=74d870f5e7445622acdc3eafae39fa7f12acf123
Comment by Cian McGovern (cian1500ww) - Wednesday, 14 December 2011, 16:17 GMT
I'm using the git version so that explains that.

You can close this as it isn't a bug.

Still weird that the licence keys don't have the same location coverage...

Loading...