Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26797 - [initscripts] /etc/rc.d/functions line 533 syntax error...

Attached to Project: Arch Linux
Opened by Gustavo Alvarez (sl1pkn07) - Tuesday, 08 November 2011, 13:03 GMT
Last edited by Tom Gundersen (tomegun) - Wednesday, 09 November 2011, 21:17 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

error when init system (in my case, reboot machine)

(see picture)

http://i.imgur.com/RRnlB.jpg


Additional info:
* package version(s) initscripts 2011.11.1-1
* config and/or log files etc.

(see pcture)

Steps to reproduce:

init/reboot system
This task depends upon

Closed by  Tom Gundersen (tomegun)
Wednesday, 09 November 2011, 21:17 GMT
Reason for closing:  Not a bug
Comment by Dave Reisner (falconindy) - Tuesday, 08 November 2011, 13:22 GMT
I think you need to fix your camera first.

I've no idea what this "auto install/update modules" service is, but I'm sure its what's at fault. Please point out the source of this.
Comment by Gustavo Alvarez (sl1pkn07) - Tuesday, 08 November 2011, 13:51 GMT
dkms?

this http://aur.archlinux.org/packages.php?ID=47570
and this http://aur.archlinux.org/packages.php?ID=47364

with initscripts 2011.11.1-1 [testing]

sl1pkn07@sL1pKn07 ~ $ sudo /etc/rc.d/dkms_autoinstaller start
Contraseña:
/etc/rc.d/functions: line 533: syntax error near unexpected token `<'
/etc/rc.d/functions: line 533: ` done < <(findmnt -runRo TARGET,FSTYPE,OPTIONS / | tac)'
:: Service auto-install/update modules for kernel 3.1.0-4-ARCH

with initscripts 2011.10.2-1 [core]

sl1pkn07@sL1pKn07 ~ $ sudo /etc/rc.d/dkms_autoinstaller start
:: Service auto-install/update modules for kernel 3.1.0-4-ARCH


PD: fix my cam? why? in darkness and without flash....
Comment by Dave Reisner (falconindy) - Tuesday, 08 November 2011, 13:55 GMT
Right. The problem is with the AUR package -- this script uses /bin/sh as the shebang rather than /bin/bash.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Tuesday, 08 November 2011, 14:29 GMT
Nice screenshot. :)

I suggest that the next step is adding a comment to the relevant AUR package (not sure if it's "dkms" or another package).
Comment by Gustavo Alvarez (sl1pkn07) - Tuesday, 08 November 2011, 14:48 GMT
ok. i frezzing initscripts to update dkms_autoinstaller script

greetings
Comment by Gustavo Alvarez (sl1pkn07) - Tuesday, 08 November 2011, 14:51 GMT
#trontonic

i dont have idea the problem is for dkms :/

in initscripts from core works perfect.

i think is not related out dkms
Comment by Dave Reisner (falconindy) - Tuesday, 08 November 2011, 14:53 GMT
No. I'm telling you that line 1 of /etc/rc.d/dkms_autoinstaller is #!/bin/sh. That is _wrong_. If you change it to #!/bin/bash everything will be fine. This is not a problem with initscripts. The AUR package should just write its own rc.d script rather than patch the crap out of the debian script.
Comment by Gustavo Alvarez (sl1pkn07) - Wednesday, 09 November 2011, 05:16 GMT
  • Field changed: Percent Complete (100% → 0%)
-
Comment by Gustavo Alvarez (sl1pkn07) - Wednesday, 09 November 2011, 21:11 GMT
#falconindy

change this and see the light of magic ;) ... hey, do not, didn't works, or part of all

yes, is a "crap" patch. but, working before :D

serenity, i make form the scratch (false) a really own big crap script to fix it (up to change initscript)

greetings and without acrimony

PD: close the "bug" please




Loading...