Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26789 - [mkvtoolnix-cli] mkvinfo depends on wxgtk library

Attached to Project: Arch Linux
Opened by xduugu (xduugu) - Monday, 07 November 2011, 23:57 GMT
Last edited by Giovanni Scafora (giovanni) - Wednesday, 30 November 2011, 00:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Since the mkvtoolnix gui was re-added and the package was split in mkvtoolnix-{cli,gtk} ( FS#26513 ), mkvinfo, which is part of mkvtoolnix-cli, complains about a missing library (see  FS#22396 ):

$ mkvinfo
mkvinfo: error while loading shared libraries: libwx_gtk2u_core-2.8.so.0: cannot open shared object file: No such file or directory

Please try to provide the cli-only version of mkvinfo instead of just moving the binary to the -gtk package. Thanks

Additional info:
* mkvtoolnix-cli 5.0.1-4
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Wednesday, 30 November 2011, 00:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in mkvtoolnix-{cli,gtk}-5.0.1-6. Thanks to xduugu.
Comment by xduugu (xduugu) - Tuesday, 08 November 2011, 00:05 GMT
Just found how it is solved in debian:

https://github.com/mbunkus/mkvtoolnix/blob/master/debian-upstream/rules#L25-36
> dh_auto_configure -- --enable-gui --docdir='$${datarootdir}/doc/mkvtoolnix-gui'
>
> ./drake -j $(NCPUS)
>
> mv src/mkvinfo src/mkvinfo-gui
> mv src/mmg/mmg src/mmg/mmg-gui
>
> ./drake clean
>
> dh_auto_configure -- --disable-gui
>
> ./drake -j $(NCPUS) default 'translations:guides'
Comment by Giovanni Scafora (giovanni) - Monday, 28 November 2011, 13:54 GMT
I cannot provide the cli-only version of mkvinfo because we should need two configure for that or two separate packages.
Is that so hard to install wxgtk package?
This is an upstream issue, please report to mkvtoolnix developers this problem.
Comment by xduugu (xduugu) - Monday, 28 November 2011, 15:13 GMT
Well, you missed the point of this report. It is an bug report, not a feature request. Even if you are not willing to follow my suggestion, it needs to be addressed some way.

$ namcap mkvtoolnix-cli-5.0.1-4-x86_64.pkg.tar.xz
mkvtoolnix-cli E: Dependency wxgtk detected and not included (libraries ['usr/lib/libwx_baseu-2.8.so.0', 'usr/lib/libwx_gtk2u_core-2.8.so.0'] needed in files ['usr/bin/mkvinfo'])

I see three possible solution:

1. Add wxgtk as dependency to mkvtoolnix-cli
Well, in this case, the split does not make sense anymore.

2. Move mkvinfo to mkvtoolnix-gtk

3. Build an gtk-free version of mkvinfo for mkvtoolnix-cli and a gui version for mkvtoolnix-gtk (that's was I suggested)
A working PKGBUILD for this solution is attached. It calls configure two times I know, but I do not understand why you dislike it.
Comment by Steven V (steabert) - Monday, 28 November 2011, 15:34 GMT
Indeed, currently the lack of dependency of mkvtoolnix-cli on wxgtk is a bug, since mkvinfo doesn't work.

Would it be possible to have only one package mkvtoolnix, with optional dependency on wxgtk for gui stuff?
Comment by xduugu (xduugu) - Monday, 28 November 2011, 17:06 GMT
> Would it be possible to have only one package mkvtoolnix, with optional dependency on wxgtk for gui stuff?

That was the case before the split. The problem was that there were lots of bug reports because wxgtk is not really optional for some programs that do not work without this dependency.
Comment by Giovanni Scafora (giovanni) - Tuesday, 29 November 2011, 22:48 GMT
Hi xduugu,

thanks a lot for your solution, you've saved my time.
I just fixed it in mkvtoolnix-{cli,gtk}-5.0.1-6 into [staging] (for boost rebuild).
If you want, you can send me a PKGBUILD, adding also support for mkvtoolnix-qt.

Loading...