Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26741 - [KDM] not running after update system

Attached to Project: Arch Linux
Opened by Sérgio Berlotto Jr (sberlotto) - Friday, 04 November 2011, 00:37 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 10 November 2011, 20:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After update my system to KDE 4.7.3-1 and Xorg 1.11.1.902-1 KDM is not running correctly.
I dont have any idea about qhat errors cause this crash, but my /var/log/errors.log is that: http://paste.archlinux-br.org/1848

Additional info:
* KDE 4.7.3-1
* Xorg 1.11.1.902-1
* Video card Intel
* Processor : Intel(R) Core(TM) i3 CPU M350 @ 2.27GHz


Steps to reproduce:
At latest version os all packages, reboot the system.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 10 November 2011, 20:04 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Some font package (maybe unofficial) doesn't run fc-cache after its installation or its removal
Comment by Easy Rider (redbaron) - Saturday, 05 November 2011, 19:31 GMT
Can confirm that. KDM don't crash, but loads very slow on my system.
Comment by Archan Paul (archan.paul) - Sunday, 06 November 2011, 13:20 GMT
I also faced the similar problem with KDM after I upgraded to KDE 4.7.3-1. After I updated the font cache with "fc-cache -f", the problem got resolved. Surprisingly the whole KDE became more responsive. I think, some font package didn't update the cache after installation.
Comment by Archan Paul (archan.paul) - Tuesday, 08 November 2011, 04:45 GMT
# fc-cache -fv
/usr/share/fonts: caching, new cache contents: 0 fonts, 8 dirs
/usr/share/fonts/100dpi: caching, new cache contents: 398 fonts, 0 dirs
/usr/share/fonts/75dpi: caching, new cache contents: 398 fonts, 0 dirs
/usr/share/fonts/TTF: caching, new cache contents: 696 fonts, 0 dirs
/usr/share/fonts/Type1: caching, new cache contents: 35 fonts, 0 dirs
/usr/share/fonts/cyrillic: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/misc: caching, new cache contents: 59 fonts, 0 dirs
/usr/share/fonts/util: caching, new cache contents: 0 fonts, 0 dirs
Comment by Amitav (amitavmohanty01) - Thursday, 10 November 2011, 17:45 GMT
Yes, it does load very slow. I have to try updating the font cache.
Comment by Easy Rider (redbaron) - Thursday, 10 November 2011, 18:19 GMT
Updating the font cache solved the problem.
Tanks Paul!

Loading...