Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26732 - [lyx] cannot locate .cls files (python 3)

Attached to Project: Arch Linux
Opened by Brian (bsquared) - Thursday, 03 November 2011, 16:48 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 03 November 2013, 14:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
python 3 causes LyX program configuration to fail. The result is that the latex .cls files are not found and this error is issued when openning a document.

Warning: Document class not available
----------------------------------------
The selected document class
article
requires external files that are not available.
The document class can still be used, but the
document cannot be compiled until the following
prerequisites are installed:
article.cls
See section 3.1.2.2 (Class Availability) of the
User's Guide for more information.

Additional info:
* package version(s)
Name : lyx
Version : 2.0.1-2

Name : texlive-core (texlive-most)
Version : 2011.23170-1

* config and/or log files etc.
lyx configure.log attached

lyx mail list thread:
http://article.gmane.org/gmane.editors.lyx.general/72703

Steps to reproduce:
Install lyx package on arch with python 3.x and python2 2.x
open lyx
open example/splash.lyx
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 03 November 2013, 14:15 GMT
Reason for closing:  Not a bug
Additional comments about closing:  texlive misconfirmation
Comment by Glyn Adgie (glynadgie) - Monday, 26 March 2012, 11:54 GMT
I have had this problem for some time on a system that I had steadily updated over several years. Having built a new system, I thought the problem might get fixed with a clean install. I kept my home directory. The problem still persisted. I looked at /usr/share/lyx/configure.py, which is used to configure Lyx, and in particular, detect for a valid Latex installation. The script creates a temporary Latex file, chklatex.ltx, and runs it. This is the contents of chklatex.ltx:

\nonstopmode\makeatletter
\ifx\undefined\documentclass\else
\message{ThisIsLaTeX2e}
\fi
\@@end

This is what I got when I ran 'latex chklatex.ltx':

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2012/dev/Arch Linux)
restricted \write18 enabled.
---! /home/glyn/.texlive/texmf-var/web2c/pdftex/latex.fmt doesn't match pdftex.pool
(Fatal format file error; I'm stymied)

This indicated a problem in ~/.texlive. I renamed ~/.texlive to ~/.texlive.old, then started Lyx. The problem was fixed.

I hope this helps.
Comment by Leslie Polzer (skypher) - Wednesday, 13 June 2012, 19:45 GMT
I have the same problem. Plus LyX always calls configure.py
Comment by Ronald van Haren (pressh) - Saturday, 17 November 2012, 16:11 GMT
Is this still an issue with 2.0.5?
Comment by Dmitry Golub (dgolub) - Monday, 12 August 2013, 12:27 GMT
Yes, there is still an issue in current (updated today) version of Arch Linux.

%> pdflatex --version
pdfTeX 3.1415926-2.5-1.40.14 (TeX Live 2013/Arch Linux)
kpathsea version 6.1.1
Copyright 2013 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty. Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Compiled with libpng 1.6.3; using libpng 1.6.3
Compiled with zlib 1.2.8; using zlib 1.2.8
Compiled with poppler version 0.24.0


%> lyx --version
LyX 2.0.6 (2013-04-29)
Built on Jul 8 2013, 14:29:45
Configuration
Host type: x86_64-unknown-linux-gnu
Special build flags: build=release use-aspell use-enchant use-hunspell
C Compiler: gcc
C Compiler LyX flags:
C Compiler flags: -D_FORTIFY_SOURCE=2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4
C++ Compiler: g++ (4.8.1)
C++ Compiler LyX flags:
C++ Compiler flags: -D_FORTIFY_SOURCE=2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -fpermissive
Linker flags:
Linker user flags: -Wl,-O1,--sort-common,--as-needed,-z,relro
Qt 4 Frontend:
Qt 4 version: 4.8.5
Packaging: posix
LyX binary dir: /usr/bin
LyX files dir: /usr/share/lyx

%> /usr/share/lyx/configure.py
(lots of output)

%> grep 'WARNING' configure.log
WARNING: Latex not usable (not LaTeX2e)

The same error on LyX start (Warning: Document class not available).
Comment by Dmitry Golub (dgolub) - Monday, 12 August 2013, 15:53 GMT
[Solved]
There was a problem with texlive (mis)configuration.
Sorry for the noise.

Loading...