Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26725 - Suspend and Hibernate not working on new Satellite L775d

Attached to Project: Arch Linux
Opened by Alexander Kyte (sublimepua) - Thursday, 03 November 2011, 01:10 GMT
Last edited by Roman Kyrylych (Romashka) - Tuesday, 20 December 2011, 10:46 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The laptop in question is a brand new satellite L775D with an a6 3400m processor and an ati 6520g gpu. Under windows, shutdown and sleep work perfectly. Under linux, suspends and hibernations do not work. The screen goes black, but the backlight is still on. The cpu fan gets noisy. When I hold down the power button after a few minutes in order to cause an ACPI shutdown, and I start it back up again, I get a black screen which does not change, even after I hold down the power button. I must remove the battery and disconnect the charger for it to reboot to a grub menu on next startup.

/var/log/pm-suspend.log shows no errors:

Initial commandline parameters:
Thu Nov 3 20:35:21 EDT 2011: Running hooks for suspend.
Running hook /usr/lib/pm-utils/sleep.d/00logging suspend suspend:
Linux lambda 3.0-ARCH #1 SMP PREEMPT Wed Oct 19 10:27:51 CEST 2011 x86_64 AMD A6-3400M APU with Radeon(tm) HD Graphics AuthenticAMD GNU/Linux
Module Size Used by
appletalk 26298 0
ipx 20395 0
p8022 1171 1 ipx
psnap 1973 2 appletalk,ipx
llc 3761 2 p8022,psnap
p8023 1068 1 ipx
cryptd 8213 0
aes_x86_64 7476 2
aes_generic 26106 1 aes_x86_64
ipv6 290983 28
joydev 9895 0
snd_hda_codec_realtek 294320 1
radeon 992259 0
ttm 54360 1 radeon
drm_kms_helper 25409 1 radeon
drm 183380 3 radeon,ttm,drm_kms_helper
i2c_algo_bit 5199 1 radeon
fglrx 2914100 86
snd_hda_codec_hdmi 22092 1
uas 8088 0
snd_hda_intel 22122 4
snd_hda_codec 77927 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
ums_realtek 4458 0
usb_storage 44263 1 ums_realtek
uvcvideo 64963 0
videodev 78006 1 uvcvideo
media 10437 2 uvcvideo,videodev
v4l2_compat_ioctl32 8292 1 videodev
psmouse 55192 0
arc4 1410 2
serio_raw 4294 0
video 11228 0
snd_hwdep 6325 1 snd_hda_codec
snd_pcm 73952 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer 19416 1 snd_pcm
snd 57818 14 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore 6146 1 snd
snd_page_alloc 7121 2 snd_hda_intel,snd_pcm
rtl8192ce 72663 0
rtl8192c_common 56295 1 rtl8192ce
rtlwifi 92129 1 rtl8192ce
processor 24256 4
mac80211 215908 3 rtl8192ce,rtl8192c_common,rtlwifi
sparse_keymap 3088 0
r8169 42643 0
i2c_piix4 8224 0
i2c_core 20133 6 radeon,drm_kms_helper,drm,i2c_algo_bit,videodev,i2c_piix4
thermal 7863 0
battery 6317 0
wmi 8347 0
evdev 9530 7
pcspkr 1819 0
mii 3995 1 r8169
ac 2376 0
k10temp 2883 0
cfg80211 160772 2 rtlwifi,mac80211
rfkill 15402 1 cfg80211
button 4470 1 fglrx
ext4 370462 1
mbcache 5817 1 ext4
jbd2 71074 1 ext4
crc16 1297 1 ext4
sr_mod 14951 0
cdrom 36329 1 sr_mod
sd_mod 28307 3
pata_acpi 3376 0
ohci_hcd 21714 0
ahci 21217 2
libahci 18885 1 ahci
pata_atiixp 3928 0
libata 173297 4 pata_acpi,ahci,libahci,pata_atiixp
ehci_hcd 39543 0
scsi_mod 131546 5 uas,usb_storage,sr_mod,sd_mod,libata
usbcore 142576 8 uas,ums_realtek,usb_storage,uvcvideo,rtlwifi,ohci_hcd,ehci_hcd
total used free shared buffers cached
Mem: 5590140 789788 4800352 0 1852 236416
-/+ buffers/cache: 551520 5038620
Swap: 6144856 0 6144856

/usr/lib/pm-utils/sleep.d/00logging suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/00powersave suspend suspend:

/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/01grub suspend suspend:

/usr/lib/pm-utils/sleep.d/01grub suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/11netcfg suspend suspend:

/usr/lib/pm-utils/sleep.d/11netcfg suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:

/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
Running hook /etc/pm/sleep.d/90alsa suspend suspend:

/etc/pm/sleep.d/90alsa suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/90clock suspend suspend:

/usr/lib/pm-utils/sleep.d/90clock suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend:

/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/95led suspend suspend:

/usr/lib/pm-utils/sleep.d/95led suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend:
ATI Catalyst driver detected, not using quirks.

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/99video suspend suspend:
kernel.acpi_video_flags = 0

/usr/lib/pm-utils/sleep.d/99video suspend suspend: success.
Thu Nov 3 20:35:24 EDT 2011: performing suspend

This is a messy bug. I truly hope that I am overlooking a simple solution.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Tuesday, 20 December 2011, 10:46 GMT
Reason for closing:  Upstream
Additional comments about closing:  thanks for documenting the fix!
Comment by Alexander Kyte (sublimepua) - Thursday, 03 November 2011, 03:25 GMT
For some reason xfce's logout menu suspend works. Is this more than a pm-suspend wrapper?
Comment by Filippo cucchetto (Cuke) - Thursday, 15 December 2011, 19:13 GMT
which kernel do you have? have you tried the 3.1.4-1? cause upgrading to 3.1.5 broke pm-suspend on my notebook.
If this happen to you too then mark this bug as duplicate of #27572
Comment by Alexander Kyte (sublimepua) - Friday, 16 December 2011, 02:08 GMT
I fixed it myself. The fix is on the bottom of the wiki page that I created for this laptop model.

https://wiki.archlinux.org/index.php/Toshiba_Satellite_L775D_S7340

Loading...