Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#26717 - grub fails to install because of a syntax error in the grub commands aif specifies

Attached to Project: Release Engineering
Opened by Thomas Dziedzic (tomd123) - Wednesday, 02 November 2011, 04:10 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Monday, 26 December 2011, 10:24 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To Dieter Plaetinck (Dieter_be)
Architecture All
Severity High
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

link to full report: http://sprunge.us/MGHY
link to /var/log/aif/aif.log: http://sprunge.us/NSdN

error describing line in aif.log: bootdev: (hd0,)

Using 2011.11.1

I had to manually set up grub in order to have a bootable system.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Monday, 26 December 2011, 10:24 GMT
Reason for closing:  Fixed
Comment by Dominik Enzinger (pr0nbaer) - Thursday, 01 December 2011, 21:48 GMT
Exactly the same Problem with Daily Build 2011.12.1
Comment by Dieter Plaetinck (Dieter_be) - Thursday, 15 December 2011, 09:34 GMT
can you try to find out if the grub package changed recently and what the corresponding upstream changelogs say that could relate to this?
Comment by Thomas Dziedzic (tomd123) - Saturday, 17 December 2011, 21:14 GMT
grub package doesn't seem to have changed at all, here is the relevant svn log:

------------------------------------------------------------------------
r141999 | ronald | 2011-11-03 16:16:38 -0500 (Thu, 03 Nov 2011) | 1 line

sign package
------------------------------------------------------------------------
r134896 | ronald | 2011-08-08 12:30:51 -0500 (Mon, 08 Aug 2011) | 2 lines

upgpkg: grub 0.97-20
 FS#25442  grub-install doesn't work on i686; add xfsprogs to optdepends and add check for it in install-grub script
------------------------------------------------------------------------

The latest official release was 2011-08-19, this is after the release of any change to grub.
Comment by Dieter Plaetinck (Dieter_be) - Friday, 23 December 2011, 16:35 GMT
hey, i couldn't figure out exactly where the bug is, but I noticed a lot of the code was old cruft, so i refactored and cleaned up the relevant functions.
i didn't test it yet, but the new code might just fix it (or introduce even more brokenness :)
the code is now in the develop branch and will be on the next testiso.
https://github.com/Dieterbe/aif/compare/25ba3d1537...531083a9a0
Comment by Dieter Plaetinck (Dieter_be) - Friday, 23 December 2011, 21:22 GMT
if anyone feels like it, feel free to test a new test iso @ http://releng.archlinux.org/isos/ when you see a 2011.12.24 or newer
Comment by Bryan (bryan) - Sunday, 25 December 2011, 10:02 GMT
Same error with archlinux-2011.12.24_10-40-01-core-x86_64.iso: grub install fails.
Comment by Dominik Enzinger (pr0nbaer) - Sunday, 25 December 2011, 11:33 GMT
jub, same here with build 2011.12.24 netinst i686...
Comment by Dominik Enzinger (pr0nbaer) - Sunday, 25 December 2011, 12:36 GMT
Just tried 2011.12.25 netinst i686... following has been printed to tty7:

1 | grub> device (hd0) /dev/sda
2 | grub> root (hd00)
3 | Filesystem type unknown, using whole disk
4 | grub> setup (hd0)
5 |
6 | Error 17: Cannot mount selected partition
7 | grub> quit

I Think the Error is on line 2, it should be "hd0,0" not "hd00"
Comment by Dieter Plaetinck (Dieter_be) - Sunday, 25 December 2011, 12:46 GMT
oops yes, i forgot a comma in my change, i amended the commit in git. there will be a testbuild 12.25 dated 14:00 soon which should have this fixed.
Comment by Bryan (bryan) - Monday, 26 December 2011, 10:04 GMT
Thanks, it works today with the archlinux-2011.12.26_04-00-01-core-x86_64 iso.

BTW (nothing to do with the issue) but shouldn't core/net-tools be part of the install by default? I know one can select it from the packages list during install, but by default it's not installed and it's weird to reboot in a unix family OS without any ifconfig command available :-)
Comment by Dieter Plaetinck (Dieter_be) - Monday, 26 December 2011, 10:24 GMT
thanks for confirming, i'll close this.
about ifconfig, i believe that's optional now.

Loading...