Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26715 - [kdesdk-poxml] Many KDE non-application packages have wrong upstream URL

Attached to Project: Arch Linux
Opened by Dan Cecile (dcecile) - Wednesday, 02 November 2011, 01:34 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 04 March 2013, 11:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



The upstream URL for this DOCBOOK to "PO" translation utility is pointing to the KDE hex editor. I'm not sure what the correct homepage is for this tool, but the current link isn't right.

This actually seems to be a general problem with all KDE packages that don't have URL specified in the PKGBUILD file. Other PKGBUILD files may also be affected similarly.

Additional info:
* kdesdk-poxml 4.7.2-1

Steps to reproduce:

Check the package details. For example:
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 04 March 2013, 11:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  kde-* 4.10.1
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 12:53 GMT
Ugh... that looks more like a makepkg bug. Adding me to assignees while I investigate.
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 13:41 GMT
So, overridding the url in split packages is not supported by makepkg. I have submitted a patch for this to be added.

This bug will be fixed with a simple rebuild once this patch is released.
Comment by Andrea Scarpino (BaSh) - Saturday, 02 June 2012, 16:37 GMT
Yep, I was sure you guys already knew about that, but I never really checked.