Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26710 - [libimobiledevice] Cannot talk to ios5 device

Attached to Project: Arch Linux
Opened by Sunny Hsu (flaminigo) - Tuesday, 01 November 2011, 15:55 GMT
Last edited by Jan de Groot (JGC) - Sunday, 16 February 2014, 13:29 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


libimobiledevice for connecting MAC mobile device cannot talk to those having ios 5.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
Connect to itouch/iphone updated to ios5.

This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 16 February 2014, 13:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  original problem has been fixed upstream since 1.1.2. see last comment
Comment by Ionut Biru (wonder) - Tuesday, 01 November 2011, 16:00 GMT
upstream didn't release a version compatible with ios5
Comment by Daniel Tobias (dant) - Sunday, 06 November 2011, 00:30 GMT
I can confirm this. I get "Unhandled Lockdown Error (-4)

seems like this was fixed in ubuntu by applying this patch

The ubuntu bug report is located here
Comment by David Hernandez (speakerhiss) - Thursday, 24 November 2011, 02:28 GMT
Same as Daniel above, I get the message when I attempt to mount iPhone 3GS iOS 5.0.1
Phone previously mounted without a problem, and Banshee was able to store music in it.

"idevice_id -l" is able to return the iPhone's UUID, and "ideviceinfo -s" is able to return general info, however "idevicepair unpair" and "idevicepair pair" both return "QueryType failed, error code -256."

Comment by Ionut Biru (wonder) - Thursday, 24 November 2011, 08:33 GMT
did anyone tested the change from comment 2?
Comment by Daniel Tobias (dant) - Thursday, 24 November 2011, 12:23 GMT
I just compiled the latest git head, I was able to get the device to pair successfully

[daniel@miscreation tools]$ ./idevicepair unpair
SUCCESS: Unpaired with device ****************************************
[daniel@miscreation tools]$ ./idevicepair pair
SUCCESS: Paired with device ****************************************

Still not able to mount and view in nautilus, "Unhandled Lockdown Error (-4)"

Is iFuse a seperate project, I'm unsure?

iPhone 4, iOS 5.0.1
Comment by Ionut Biru (wonder) - Thursday, 24 November 2011, 12:24 GMT
nautilus uses gvfs-afc
Comment by Daniel Tobias (dant) - Thursday, 24 November 2011, 12:44 GMT
I am unsure what I should try next, I'm about to downgrade my second device to 4.3.5 just to be 100% certain my setup is correct
Comment by Daniel Tobias (dant) - Sunday, 29 January 2012, 09:27 GMT
Howdy sorry for the long delay, finally got around to rebuilding with the patch. works flawlessly, I can once again access the device through nautulis and access music through rhythmbox

attached pkgbuild and the patch to make things easy


(Sorry wrong PKGBUILD use v2, cannot delete the first)
Comment by Andre (akspecs) - Monday, 23 April 2012, 23:53 GMT
Interestingly enough the new libimobiledevice package that was released recently still gives me the unhandled lockdown error. In the past, around december I was able to install libimobiledevice-git from the aur, but now it requires a newer usbmuxd (which i tried building but it causes errors on my system and I am no longer able to shutdown/reboot/sleep through GUIs).

Using Tobias's PKGBUILD I am able to build and install this package without problems and mount and view my ios 5 devices through nautilus. But I was also used to being able to mount something along the lines of "Documents on <device name>" which listed the applications which allowed file sharing. Is there a way to get this back?
Comment by John (graysky) - Tuesday, 22 May 2012, 16:02 GMT
@dant - that patch and PKGBUILD-v2 works for me. I am now able to again mount via ifuse my iPad2 (iOS 5.1.1).
@wonder - will you repackage with this patch?
Comment by MG (elmurato) - Wednesday, 30 May 2012, 13:48 GMT
If I try to compile it with PKGBUILD-v2 (makepkg -s PKGBUILD) I get a error message claiming that swig-version-check.patch is missing. Where do I get that? Thanks for your help...

[elmurato@Thinkpad-X201 libimobiledevice]$ makepkg -s
==> Erstelle Paket: libimobiledevice 1.1.1-3 (Mi 30. Mai 15:44:49 CEST 2012)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
-> Lade libimobiledevice-1.1.1.tar.bz2 herunter...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 280 100 280 0 0 1346 0 --:--:-- --:--:-- --:--:-- 1618
100 449k 100 449k 0 0 163k 0 0:00:02 0:00:02 --:--:-- 188k
==> FEHLER: swig-version-check.patch wurde nicht im build Verzeichnis gefunden und ist keine URL.
Comment by Daniel Tobias (dant) - Thursday, 31 May 2012, 09:22 GMT Comment by MG (elmurato) - Thursday, 31 May 2012, 10:15 GMT
Thank you! Now my 3GS with iOS 5.1.1 shows up again ;)
Comment by John (graysky) - Thursday, 21 June 2012, 06:03 GMT
@wonder - are you still on the fence with the patch that dant proposed? I can tell you that without it, no iOS 5.1.1 devices work for me (tested with iPad2 and iPhone 4S).
Comment by Sunny Hsu (flaminigo) - Thursday, 21 June 2012, 19:44 GMT
Neither doesn't work on iphone 4 with iOS 5.1.1. No device mount point is shown after plugging into the USB slot.
Comment by Ionut Biru (wonder) - Thursday, 21 June 2012, 20:29 GMT
Last time i tried to update libimobiledevice, they broke the API and gvfs and other apps that depended on it weren't ready.
I'll see what i can do when I have time.
Comment by Jerome Poulin (ticpu) - Thursday, 28 June 2012, 03:09 GMT
After compiling the new PKGBUILD-v2 and replacing the lib, I ran lsof -n | grep libimobiledevice and killed everything using it. Now after launching Nautilus it detected my documents, apps. However, banshee was not able to copy music to the device yet. iPhone 4 iOS 5.1.1
Comment by Greg (dolby) - Saturday, 17 November 2012, 02:10 GMT
Is this still a problem?
Comment by duane (duanezz) - Friday, 03 May 2013, 17:42 GMT
I'm very new to Ubuntu. Can somebody please tell me how to impliment the above patch, step by step, including commands?

Much appreciated
Comment by Eric Belanger (Snowman) - Wednesday, 15 May 2013, 04:58 GMT
Is it fixed in libimobiledevice 1.1.5-1 ?
Comment by John (graysky) - Wednesday, 15 May 2013, 07:40 GMT
@duane - Arch != Ubuntu.
@Eric - No, when I plug in my ipad, Thunar only sees 'Documents on iPad':

From dmesg:
[ 802.682496] usb 7-2: new high-speed USB device number 2 using xhci_hcd
[ 802.701918] usb 7-2: ep 0x2 - rounding interval to 8 microframes, ep desc says 10 microframes
[ 802.701925] usb 7-2: ep 0x81 - rounding interval to 8 microframes, ep desc says 10 microframes
[ 802.706136] usb 7-2: ep 0x2 - rounding interval to 8 microframes, ep desc says 10 microframes
[ 802.706143] usb 7-2: ep 0x81 - rounding interval to 8 microframes, ep desc says 10 microframes

When I attempt to mount it, dmesg:
[ 822.163918] pool[3117]: segfault at 300000003 ip 00007f2896a27e96 sp 00007f289386edd0 error 6 in[7f2896a1c000+1a000]

% pacman -Ss libimobile
extra/libimobiledevice 1.1.5-1 [installed]
Is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux
Comment by Daniel Tobias (dant) - Sunday, 16 February 2014, 13:19 GMT
I'm not sure the comment above is experiencing th same problem. The bug was originaly about a lockdown error with IOS 5 only. The patch in this thread that originally fixed it has been upstream since 1.1.2. (I suggest this be marked fixed)

I have not used an IOS device for the last few years, but I have just tried connecting an ipad2 with IOS 7 and have no issues at all. connects first try, can access documents and folders no problem.

IOS 5 is old news now. If graysky still has problems he should probably create a new bug report