Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26707 - tumbler + ffmpegthumbnailer + gstreamer0.10 = no video tumbnails + tumblerd freezes

Attached to Project: Arch Linux
Opened by Marek Kozlowski (guayasil) - Tuesday, 01 November 2011, 11:56 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 25 April 2012, 00:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

$ rm ~/.config/Thunar ~/.cache/Thunar ~/.thumbnails
# pacman -S tumbler ffmpegthumbnailer gstreamer0.10

No video tumbnails for any *.avi files etc.
If I insert my external USB HDD /usr/lib/tumbler-1/tumblerd seems to freeze: `lsof' shows that all video files in open directories of that HDD are open by it. Therefore no normal dismounting works.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 25 April 2012, 00:04 GMT
Reason for closing:  Won't fix
Additional comments about closing:  It's up to the user to install any needed gstreamer plugins. Report upstream if tumbler locks up or otherwise misbehaves.
Comment by Marius Ladegård Meyer (mariusmeyer) - Saturday, 26 November 2011, 19:54 GMT
This affects me as well. Particularly, tumbler may try to generate thumbnails for partially downloaded video files, which lead to a system crash for me yesterday as tumbler gobbled up all my RAM.
Comment by Sergey Demchenko (hello_world) - Tuesday, 20 December 2011, 15:42 GMT
Affects me too. After installing gstreamer0.10 package, I can't see any (new) video thumbnails.
Comment by Marek Kozlowski (guayasil) - Thursday, 05 January 2012, 21:22 GMT
If you confirm the bug could you change its status to `confirmed'? It affects you but for over 2 months it is still unassigned and unconfirmed and no activity happens...
Comment by Marius Ladegård Meyer (mariusmeyer) - Friday, 27 January 2012, 23:24 GMT
On a completely updated machine, video thumbnails still do not work as of today. On my system, tumblerd no longer locks up the system when opening a folder with lots of video files, but no thumbnails are displayed either. Are there any commands I can run to give more detailed debug info on this?

EDIT: Even though tumblerd does not lock up the system, it still prevents unmounting of removable media as before.
Comment by stephen (colbert) - Saturday, 11 February 2012, 19:27 GMT
I have this issue as well, I have no thumbnails for any video files (.flv, .mkv, .mov, .mp4, .mpg, .avi, you name it). Photo thumbnails randomly worked for a while, but not any more. Don't know what output to include, but using all up-to-date packages: thunar, ffmpegthumbnailer, tumbler, etc.
Comment by maxime (hush-hush) - Sunday, 12 February 2012, 22:49 GMT
I have the same issue on my up to date archlinux x86_64 (do not crash my system, but no video thumbnail and lock umounting).
Also this problem appear after the version 0.1.21-3 of tumbler. If I downgrade tumbler to 0.1.21-3 it works just fine.
Comment by stephen (colbert) - Tuesday, 14 February 2012, 07:17 GMT
I have downgraded to 0.1.21-3 of tumbler and still have no thumbnails for video files, unfortunately. I'll try more older versions.
Comment by Sergey Demchenko (hello_world) - Tuesday, 14 February 2012, 09:54 GMT
I tried all versions in a row from 0.1.21-3 to oldest in A.R.M. No thumbnails with any.
Comment by servilvo (servilvo) - Saturday, 10 March 2012, 16:15 GMT
I had the same issue. But now it works. Try this:

pacman -S gstreamer0.10-plugins ffmpegthumbnailer
rm ~/.thumbnails -r
pkill thunar
pkill tumbler

run thunar
Good luck!

Comment by Marek Kozlowski (guayasil) - Saturday, 10 March 2012, 17:05 GMT
I can confirm -- now it works!.

I think there is a mistake in dependencies:
`tumbler' should require `gstreamer0.10-plugins' not `gstreamer0.10' for video thumbnails. For all (complete set of!) plugins it works fine and doesn't freeze.
Please: change the (optional) dependencies!
Comment by stephen (colbert) - Saturday, 10 March 2012, 22:26 GMT
Hell yeah! I can also confirm using servilvo's comment above, followed exactly, that thumbnails do in fact work now! Thanks so much servilvo :) :D
Comment by Sergey Demchenko (hello_world) - Monday, 19 March 2012, 18:05 GMT
servilvo, guayasil, thanx men. Thumbnails works at last.
Comment by maxime (hush-hush) - Monday, 19 March 2012, 22:35 GMT
Works for me too. But when I install gstreamer0.10-plugins it ask me which one I want between:

gstreamer0.10-bad
gstreamer0.10-bad-plugins
gstreamer0.10-base-plugins
gstreamer0.10-ffmpeg
gstreamer0.10-good-plugins
gstreamer0.10-ugly-plugins

Only gstreamer0.10-good-plugins works (for me) the other one doesn't fix anything.

Thanks for the fix anyway !
Comment by Ronald van Haren (pressh) - Tuesday, 20 March 2012, 08:28 GMT
@Evangelos: You might want to add a(n optional) dependency to gstreamer0.10-good-plugins. Not sure if anything else is needed, I don't use tumbler/thunar.
Comment by Jay (GSF1200S) - Friday, 30 March 2012, 09:06 GMT
I had the same issue running the latest version of tumbler. To fix it, I had to install gstreamer0.10-ffmpeg. I already had gstreamer0.10-good-plugins, so I'm not sure if thats necessary.
Comment by Evangelos Foutras (foutrelis) - Friday, 13 April 2012, 19:19 GMT
The optional dependency on gstreamer0.10 is because tumbler-gst-thumbnailer.so links to libgstreamer-0.10.so.0.

If tumbler misbehaves in the absence of certain gstreamer plugins, that should probably be reported upstream. (The normal behavior would be not to display any thumbnails, but freezing/using up all the memory/etc doesn't sound right.)
Comment by Marek Kozlowski (guayasil) - Friday, 13 April 2012, 19:22 GMT
BTW: On a newly installed notebook I've omitted `ffmpegthumbnailer' but installed all the gstreamer plugins. Works fine! Maybe ffmpegthumbnailer is an extra package and should be *not* installed?

Loading...