Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26694 - [grass] wxpython does not work with grass

Attached to Project: Community Packages
Opened by David Campbell (Davekong) - Sunday, 30 October 2011, 21:22 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 14 December 2011, 18:18 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After installing grass and wxpython, trying to use grass in GUI mode fails. There are a number of errors encountered in the file "/opt/grass-6.4.1/etc/wxpython/gis_set.py". The file appears to be written in python2.x, but is being parsed as though it were python3.x.

package version: 6.4.1-4

To reproduce start grass from a terminal:
- - - - - - - - - - - - - - - - - - - - - - - - - - - -

$ grass64
WARNING: Searched for a web browser, but none found.

WELCOME TO GRASS Version 6.4.1 2011

1) Have at your side all available GRASS tutorials

2) When working on your location, the following materials
are extremely useful:
- A topo map of your area
- Current catalog of available computer maps

3) Check the GRASS webpages for feedback mailinglists and more:
http://www.grass-gis.org
http://grass.osgeo.org

Hit RETURN to continue

Starting GRASS ...
File "/opt/grass-6.4.1/etc/wxpython/gis_set.py", line 466
except StandardError, e:
^
SyntaxError: invalid syntax
Error in GUI startup. If necessary, please
report this error to the GRASS developers.
Switching to text mode now.
Hit RETURN to continue...
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 14 December 2011, 18:18 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Moved to AUR
Comment by Thomas Dziedzic (tomd123) - Sunday, 30 October 2011, 21:38 GMT
did you relogin since you installed the package?
Comment by David Campbell (Davekong) - Sunday, 30 October 2011, 21:45 GMT
Doing "export GRASS_PYTHON=python2" allows the GUI to work. If there is not a better solution, maybe add a comment during installation mentioning this.
Comment by Alexander F Rødseth (xyproto) (trontonic) - Sunday, 30 October 2011, 21:50 GMT
Confirmed, x86_64. How about adding GRASS_PYTHON=python2 and export GRASS_PYTHON to /usr/bin/grass64 in the package.
Comment by David Campbell (Davekong) - Sunday, 30 October 2011, 21:51 GMT
@tomd123: No, that works, thanks. Maybe this should be mentioned.
Comment by Thomas Dziedzic (tomd123) - Sunday, 30 October 2011, 22:35 GMT Comment by David Campbell (Davekong) - Sunday, 30 October 2011, 23:11 GMT
Sorry, missed it. A single line with no empty lines around it is pretty hard to spot when installing several packages. I think people often miss post-install messages because they can be hard to see, but I don't know what the best solution is, and the problem might be best solved with some change to pacman.

It would be nice if the user didn't have to relogin, but I don't think it is that much of an issue if it would complicate the install.

Loading...