Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26649 - [empathy] depends on evolution-data-server

Attached to Project: Arch Linux
Opened by Shanto (Shanto) - Thursday, 27 October 2011, 17:10 GMT
Last edited by Ionut Biru (wonder) - Friday, 28 October 2011, 16:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Should evolution-data-server be a dependency for empathy? Without this, empathy on a fresh installation fails to run while loading libebook-1.2.so.12 (which comes from evolution-data-server).
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 28 October 2011, 16:03 GMT
Reason for closing:  Not a bug
Comment by Shanto (Shanto) - Thursday, 27 October 2011, 17:13 GMT
Also gnutls for libgnutls.so.28.
Comment by Ionut Biru (wonder) - Thursday, 27 October 2011, 17:27 GMT
evolution-data-server and gnutls are already met.

empathy->folks->evolution-data-server->gnome-online-accounts->libsoup->glib-networking->gnutls

no idea what you have done
Comment by Shanto (Shanto) - Thursday, 27 October 2011, 17:37 GMT
I tried to make empathy work on a gnome 3.0* desktop with "pacman -Sy empathy". empathy pulled in folks but not the rest.

* I couldn't update that system to gnome 3.2 stack because 800MB+ was just too much for a slow connection there.
Comment by Ionut Biru (wonder) - Thursday, 27 October 2011, 17:40 GMT
well, you already have evolution-data-server but old so dependencies are met. we don't have versioned dependency just to avoid a massive breakage.

the only supported way is to fully update your system
Comment by Shanto (Shanto) - Friday, 28 October 2011, 12:47 GMT
No I understand and fully agree. That's a what a rolling release is. While I update my own systems every few days/week, systems operated by non-tech people around just get out of sync. Neither they can do it themselves, nor I can schedule unattended updates due to the risk of breakage.

Actually, I ended up with a complete update of the affected system overnight. I also realize that *partial* install/update packages on out-of-sync systems should be avoided. All good now. This issue should be closed or declared invalid.

Q: How do I find dependency paths like "empathy->folks->evolution-data-server->gnome-online-accounts->libsoup->glib-networking->gnutls" myself? I assume you didn't make this by hand. Is there any tool that answers questions like "does empathy pull in gnutls? through which packages?"
Comment by Ionut Biru (wonder) - Friday, 28 October 2011, 12:52 GMT
pactree empathy

Loading...