Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26590 - [lmms] broken support for VST plugins

Attached to Project: Community Packages
Opened by Martin Kühne (mar77i) - Sunday, 23 October 2011, 17:14 GMT
Last edited by Lukas Fleischer (lfleischer) - Saturday, 17 November 2012, 12:52 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I was the guy that created lmms-vst in aur, because a friend of mine was having trouble using that feature and my modification made it work. I did that instead of checking the existing lmms PKGBUILD well enough. It says for VST support just wine will enable the feature, but also the package has to be compiled differently for adding support for this.

So, either fix VST support in community/lmms by passing -USE=vst to cmake or remove the wine optdep and let my package provide support for that, as in [1]. Thinking about it, the second option seems more reasonable, especially in case that -USE=vst will make wine a makedepend. I did not do any research on that however.

Additional info:
* current ver. 4.1.12

[1] https://aur.archlinux.org/packages/lm/lmms-vst/PKGBUILD
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Saturday, 17 November 2012, 12:52 GMT
Reason for closing:  Implemented
Additional comments about closing:  Implemented in 0.4.13-2.
Comment by Martin Kühne (mar77i) - Sunday, 23 October 2011, 17:22 GMT
indeed, after testing it, I can confirm VeSTige support has been excluded when wine isn't present at buildtime.
Comment by Ray Rashif (schivmeister) - Sunday, 05 August 2012, 06:21 GMT
Then our package should make wine a makedep. IIRC it has always been like this, I don't know why it was never brought into the makedep array.

Loading...