Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26579 - [slim] special users "console" and "exit" fail.

Attached to Project: Arch Linux
Opened by René Herman (rene) - Sunday, 23 October 2011, 02:10 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 27 January 2013, 08:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Roman Kyrylych (Romashka)
Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No



The special usernames "console" and "exit" do not work within Arch Linux. I believe this bug is related to PAM and as such not purely upstream.

Additional info:
* package version(s)


* config and/or log files etc.

Just the default SLiM console_cmd (/usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login") in /etc/slim.conf. Haven't found relevant logs.

Steps to reproduce:

Type "console" or "exit" at the slim login prompt.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 27 January 2013, 08:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  slim 1.3.5-1
Comment by Gaetan Bisson (vesath) - Sunday, 23 October 2011, 03:31 GMT
I won't have much time to investigate this in the near future; any help/insight is welcome! :)
Comment by René Herman (rene) - Sunday, 23 October 2011, 12:45 GMT
I won't be able to either for at least the coming two weeks, but if no one has beaten me to it by then, I'll do some further digging. It's not a high priority thing anyway...
Comment by René Herman (rene) - Monday, 31 October 2011, 21:53 GMT
(only a note for now: report is still current for 1.3.2-6)
Comment by René Herman (rene) - Tuesday, 08 November 2011, 01:21 GMT
SLiM does not work with ConsoleKit currently and I have replaced it with LXDM. Won't be following up therefore; if no one else wants this bug open, I guess it can be closed.
Comment by Gaetan Bisson (vesath) - Tuesday, 08 November 2011, 05:24 GMT
I decided to stop maintaining SLiM in Arch, as I stopped using it a while ago and upstream seems to have abandoned it. Maybe another dev will take over, or somebody will come up with a patch.
Anyway, this bug should remain open as long as it stands and SLiM is in the official repos.
Comment by René Herman (rene) - Saturday, 12 November 2011, 03:48 GMT
I just hit upon the ConsoleKit problem:

I will for the time being be using SLiM again and will try and see if I can investigate this issue a bit next week. It, unfortunately, hasn't fixed itself yet after getting the ConsoleKit stuff sorted.
Comment by Philip (nuc) - Tuesday, 08 May 2012, 23:25 GMT
SLiM supports ConsoleKit/PolicyKit now (v. 1.3.3) but the bug is still existent.
Comment by Tobias Powalowski (tpowa) - Wednesday, 09 May 2012, 07:17 GMT
Perhaps a stupid question is xterm installed?
Comment by Philip (nuc) - Wednesday, 09 May 2012, 11:49 GMT
it is.
Comment by mattia (nTia89) - Saturday, 15 September 2012, 17:33 GMT
here the same:
with "console" or "exit" i get only a black screen with the X (of X server) cursor

i have xterm and latest slim-1.3.4-3, and

login_cmd exec dbus-launch --exit-with-session --sh-syntax openbox-session
Comment by René Herman (rene) - Saturday, 15 December 2012, 07:57 GMT
I wouldn't know how this can have ever happened, but current slim is running the special users console and exit though PAM, which is clearly not the original intent. Worse still... somebody thought that you escape a quotation-sign in C++ by doubling it up. I have attached a patch to the PKGBUILD and a "console-exit.patch" that make users "console" and "exit" work again.

Note; It is expected that you can't login as root on this console. That's nothing to do with slim, and only with PAM disallowing root logins on what it thinks is not a secure tty (pts/0) -- assuming you have PAM setup that way (it is normally in Arch).

Also note: this comments the console_cmd entry in the default config file. Using the source-default one allows scaling the terminal to the current screen-size. In any case note that the original console_cmds, both the source-default one and the conf-default one, don't work anyway due to that mentioned quote-confusion.

Roman: okay to apply?
Comment by René Herman (rene) - Saturday, 19 January 2013, 11:08 GMT
Upon this getting a new assignee... I did just now notice that, of course, users "console" and "exit" are then available to anyone, whereas not every setup may want to allow people to exit and/or login on a console. That seems to be the standard, intended slim behaviour but given that it didn't use to in fact work, this change may have implications some may not agree with, I suppose.
Comment by Evangelos Foutras (foutrelis) - Saturday, 26 January 2013, 17:56 GMT
Both exit and console work for me (the latter assuming xterm is installed).

Can you test with slim 1.3.5-1?
Comment by René Herman (rene) - Saturday, 26 January 2013, 19:37 GMT
I haven't been using SLiM for a while now; I've quite had it with that thing. The enlightening ChangeLog for 1.3.5 says that "some bugs" got fixed... If it works for you, it's probably fixed upstream, and I guess this can be closed.