Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26571 - [python2-poppler] Broken after poppler 0.18.0 update

Attached to Project: Community Packages
Opened by speps (archspeps) - Saturday, 22 October 2011, 16:54 GMT
Last edited by Ray Rashif (schivmeister) - Saturday, 22 October 2011, 19:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


poppler 0.18.0 breaks API, all pixbuf related functions are gone.
python2-poppler needs to be ported by upstream to the new API in order to work.

This simple sed line fixes the incompatibility:

# poppler 0.18.0 fix
sed -i "/pixbuf/,/^)/d" poppler.defs

Additional info:
package version: 0.12.1-5

Steps to reproduce:
$ python2
Python 2.7.2 (default, Jun 29 2011, 11:10:00)
[GCC 4.6.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import poppler
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: /usr/lib/python2.7/site-packages/ undefined symbol: poppler_page_render_to_pixbuf_for_printing
   PKGBUILD (1.1 KiB)
This task depends upon

Closed by  Ray Rashif (schivmeister)
Saturday, 22 October 2011, 19:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Update rolled to testing
Comment by Alexander F Rødseth (xyproto) (trontonic) - Saturday, 22 October 2011, 17:11 GMT
Able to reproduce.