Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26562 - samba regularly crashes (INTERNAL ERROR: Signal 11) (FS#26560 related?)

Attached to Project: Arch Linux
Opened by JM (fijam) - Saturday, 22 October 2011, 12:44 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 28 October 2011, 14:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Every few minutes I am getting the following in the logs:

$ cat /var/log/samba/smbd.log
[2011/10/22 14:02:20.738675, 0] printing/print_cups.c:475(cups_async_callback)
failed to recv pcap blob
[2011/10/22 14:15:21.069167, 0] lib/fault.c:47(fault_report)
===============================================================
[2011/10/22 14:15:21.071619, 0] lib/fault.c:48(fault_report)
INTERNAL ERROR: Signal 11 in pid 6403 (3.6.0)
Please read the Trouble-Shooting section of the Samba3-HOWTO
[2011/10/22 14:15:21.074617, 0] lib/fault.c:50(fault_report)

From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2011/10/22 14:15:21.076863, 0] lib/fault.c:51(fault_report)
===============================================================
[2011/10/22 14:15:21.077301, 0] lib/util.c:1116(smb_panic)
PANIC (pid 6403): internal error
[2011/10/22 14:15:21.102876, 0] lib/util.c:1220(log_stack_trace)
BACKTRACE: 21 stack frames:
#0 /usr/sbin/smbd(log_stack_trace+0x29) [0xb727d169]
#1 /usr/sbin/smbd(smb_panic+0x28) [0xb727d268]
#2 /usr/sbin/smbd(+0x42e4d2) [0xb726c4d2]
#3 [0xb6e1c400]
#4 /usr/lib/libgnutls.so.28(+0x88484) [0xb674f484]
#5 /usr/lib/libgnutls.so.28(+0x87b65) [0xb674eb65]
#6 /usr/lib/libgnutls.so.28(gnutls_global_init+0xd3) [0xb66f5103]
#7 /usr/lib/libcups.so.2(httpInitialize+0x62) [0xb6c378c2]
#8 /usr/lib/libcups.so.2(_httpCreate+0x59) [0xb6c37949]
#9 /usr/lib/libcups.so.2(httpConnectEncrypt+0x42) [0xb6c39f12]
#10 /usr/sbin/smbd(+0x403e09) [0xb7241e09]
#11 /usr/sbin/smbd(cups_cache_reload+0x269) [0xb7244f99]
#12 /usr/sbin/smbd(pcap_cache_reload+0x124) [0xb7241a04]
#13 /usr/sbin/smbd(+0x708481) [0xb7546481]
#14 /usr/sbin/smbd(+0x12eefc) [0xb6f6cefc]
#15 /usr/sbin/smbd(run_events_poll+0x11c) [0xb728eefc]
#16 /usr/sbin/smbd(+0x4512fb) [0xb728f2fb]
#17 /usr/sbin/smbd(_tevent_loop_once+0xa8) [0xb72900c8]
#18 /usr/sbin/smbd(main+0x1234) [0xb6ee0574]
#19 /lib/libc.so.6(__libc_start_main+0xf3) [0xb6a20223]
#20 /usr/sbin/smbd(+0xa2ba1) [0xb6ee0ba1]
[2011/10/22 14:15:21.116244, 0] lib/fault.c:372(dump_core)
dumping core in /var/log/samba/cores/smbd
[2011/10/22 14:15:21.139239, 0] printing/print_cups.c:475(cups_async_callback)
failed to recv pcap blob

Additional info:
Samba 3.6.0-8
Cups 1.5.0-1
gnutls 3.0.4-2

may be related to: https://bugs.archlinux.org/task/26560

/var/log/samba/cores/smbd attached
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 28 October 2011, 14:01 GMT
Reason for closing:  Fixed
Comment by JM (fijam) - Saturday, 22 October 2011, 12:47 GMT
I cannot attach the core file (1MB) for reasons unknown.
Comment by Tobias Powalowski (tpowa) - Tuesday, 25 October 2011, 06:54 GMT
Status on 3.6.1 in testing?
Comment by JM (fijam) - Tuesday, 25 October 2011, 07:40 GMT
This is definitely caused by  FS#26560  and architecture-related (VIA C7)

Samba crashing is just a result of gnutls segfaulting.

Loading...