Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26554 - nl80211 driver initialization failed

Attached to Project: Arch Linux
Opened by Amitav (amitavmohanty01) - Friday, 21 October 2011, 14:38 GMT
Last edited by Ionut Biru (wonder) - Monday, 28 November 2011, 12:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I am using Broadcom-wl drivers for BCM4311 wireless card and my kernel version is 3.0. When I run hostapd from the initscript I do get any lines in /var/log/*.log. Running it directly from the command line I get the following lines:

Configuration file: /etc/hostapd/hostapd.conf
nl80211: 'nl80211' generic netlink not found
nl80211 driver initialization failed.
rmdir[ctrl_interface]: No such file or directory

Additional info:
* package version(s): hostapd-0.7.3-5

N.B.:http://linux-tinkering.blogspot.com/2008/12/wifi-access-point-configuration.html might shed some light.
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 28 November 2011, 12:20 GMT
Reason for closing:  Not a bug
Additional comments about closing:  b43 ftw
Comment by Amitav (amitavmohanty01) - Thursday, 10 November 2011, 17:55 GMT
After updating linux kernel to version 3.1, I updated broadcom-wl driver. Now, I am getting the following error:
hostapd /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf
nl80211: Failed to set interface wlan0 into AP mode
nl80211 driver initialization failed.
rmdir[ctrl_interface]: No such file or directory
ELOOP: remaining socket: sock=4 eloop_data=0x20d73f0 user_data=0x20d8b90 handler=0x42daa0
ELOOP: remaining socket: sock=6 eloop_data=0x20db0f0 user_data=(nil) handler=0x436a90
Comment by Amitav (amitavmohanty01) - Wednesday, 23 November 2011, 17:20 GMT
Changing to b43 driver solved the issue.

Loading...