Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26524 - [xfce4] Trash applet races with Trash desktop-icon

Attached to Project: Arch Linux
Opened by René Herman (rene) - Wednesday, 19 October 2011, 14:13 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 09 March 2012, 08:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



For a long time, my xfce desktop would come up without the Trash icon in about 5% to 15% of bootups/restarts. Tried inserting delays here and there but nothing worked until I noticed I also had placed the Trash Applet on my panel. Removing the trash applet fixed the issue: the trash desktop icon is now always present on bootup. Something seems to be racing, therefore...

Note, this issue is not (primarily) involved with the no. 1 google hit for xfce an Trash icon stuff. I have all that gvfs stuff working normally. Things just break (a bit, sometimes) when also having the Trash Applet present on the panel.

Likely an upstream issue, but I'm hoping this bugzilla can work as a funnel. As a user, it's a little undoable to maintain accounts on bugzillas for this many upstream packages...

Additional info:
* package version(s)

Has affected package versions from, say, a year ago to now. My xfce4-panel version is currently 4.8.6-1.

* config and/or log files etc.


Steps to reproduce:

Have a Trash desktop-icon, place the Trash Applet on a panel, and restart a few dozen times. Maybe -- if your system doesn't have wildly different timing parameters.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 09 March 2012, 08:17 GMT
Reason for closing:  Upstream
Comment by Tobias Powalowski (tpowa) - Thursday, 08 March 2012, 13:53 GMT
Still an issue?
Comment by René Herman (rene) - Thursday, 08 March 2012, 17:38 GMT
I had simply removed the Trash applet. Difficult to say for certain, since it's a timing issue but when I just now tested, I couldn't reproduce. If it's still there, then it seems to have at least gotten more rare.

EDIT: It just triggered again, so, yes, still an issue.