Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26499 - [netcfg] OpenVPN interfaces are tracked as INTERFACE value, not tun/tap device.

Attached to Project: Arch Linux
Opened by Splex (plexor) - Tuesday, 18 October 2011, 06:30 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 30 April 2013, 01:08 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Jouke Witteveen (jouke)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
The actual OpenVPN tap/tun interfaces are not tracked by netcfg. This causes multiple OpenVPN profiles to be mutually exclusive when following the example profile. Additionally, it can cause confusion when attempting to disconnect a profile by specifying the actual tap/tun interface.

Additional info:
netcfg 2.6.8-1

/etc/network.d/examples/openvpn:
CONNECTION="openvpn"
INTERFACE="ignore"
OVPN_CONFIG="/etc/openvpn/example/openvpn.conf"
OVPN_PID_FILE="/tmp/openvpn.example.pid"
OVPN_FLAGS=""

Steps to reproduce:
1.) Create two OpenVPN profiles, based on the example (with INTERFACE="ignore"), changing OVPN_CONFIG/OVPN_PID_FILE accordingly.
2.) Bring the first profile up.
3.) Bring the second profile up.

Actual Results:
The first profile will be disconnected before the second profile is brought up. This is due to the connections literally being tracked as the INTERFACE value, "ignore."

Expected Results:
The script should track the actual tun/tap interface used by the OpenVPN process (which may be dynamically allocated.) One could still choose to have the mutually exclusive connection behaviour by creating multiple OpenVPN config files that use the same 'dev' value.

Workaround:
Ensure each profile has a unique INTERFACE name (ignore1, ignore2, etc.)
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 30 April 2013, 01:08 GMT
Reason for closing:  Won't fix
Additional comments about closing:  netcfg has been moved to AUR

Loading...