Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26485 - [xorg-server-common & xorg-setxkbmap parameter -variant "Error loading new keyboard descriptio"]

Attached to Project: Arch Linux
Opened by Daniel (8472) - Monday, 17 October 2011, 11:57 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 09 November 2011, 10:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After upgrading to xorg-server-common 1.11.1-2 (Last Updated: 2011-10-11) and the rest from xorg-*, while using `setxkbmap -option '' -option grp:switch,grp:alt_shift_toggle,lv3:ralt_switch,eurosign:e us,de,sk -variant ,qwerty,qwerty`
I get this error: "Error loading new keyboard description".
In /var/log/Xorg.0.log is this error present: "[ 9441.812] (EE) Error loading keymap /tmp/server-0.xkm".

Additional info:
* package version(s) - xorg-server-common 1.11.1-2 , xorg-setxkbmap 1.2.0-2
* config and/or log files etc. - /var/log/Xorg.0.log

Steps to reproduce:
`setxkbmap -option '' -option grp:switch,grp:alt_shift_toggle,lv3:ralt_switch,eurosign:e us,de,sk -variant ,qwerty,qwerty`

opened debate in here (with currently at least one another affected user, but might be more):
https://bbs.archlinux.org/viewtopic.php?pid=1004655
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 09 November 2011, 10:27 GMT
Reason for closing:  Upstream
Additional comments about closing:  Upstream intended change. Not fixing this, complain upstream if you want it reverted.
Comment by Daniel (8472) - Wednesday, 19 October 2011, 21:18 GMT
so, I've finally found the reason of mine error.
I was using the QWERTY variant for the DE layout, and this has changed with the xorg-* update.
in this file is also an list of variants "/usr/share/X11/xkb/rules/xorg.lst" , and the line with QWERTY for DE is gone.
but it was present before in the form of this entry: "qwerty de: qwerty"

thus now I have to use the -variant in the form ",,qwerty":
[code]setxkbmap -option '' -option grp:switch,grp:alt_shift_toggle,lv3:ralt_switch,eurosign:e us,de,sk -variant ,,qwerty[/code]

damn it, I want it back!
I'm curious, if this has been caused by decision at the Xorg devepers, or if this is an mistake of package maintainer?
Comment by Jan de Groot (JGC) - Monday, 24 October 2011, 13:56 GMT
This is caused by an upstream commit in xkeyboard-config:
http://cgit.freedesktop.org/xkeyboard-config/commit/?id=fd830658afb205d998fde9bf1a760347476884af

Looks like you'll have to use de(us) instead of de(qwerty).
Comment by Daniel (8472) - Monday, 24 October 2011, 15:06 GMT
Thank you Jan for your help.
It works, though at first I was confused about how to get back the special german characters, till I found that right Alt has to be used in order to invoke them using the same key positions (with right Alt pressed) as before.
Hm, why did they get rid of the de(qwerty)? I liked it more that way. Now a man has to get used for new key combinations. Couldn't they simply leave it in there, while including the new de(us) too?

Loading...