Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26466 - [gnash-gtk] gnashplugin in Firefox crash at Flash on Websites

Attached to Project: Arch Linux
Opened by dennis (ds2k5) - Sunday, 16 October 2011, 07:39 GMT
Last edited by Jan Steffens (heftig) - Thursday, 11 October 2012, 20:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: can not view flash-videos a youtube for example, or sites with flash menus etc.

Additional info:
gnash-common 0.8.9-4
gnash-gtk 0.8.9-4
firefox 7.0.1-1

about:plugins in firefox

Shockwave Flash

Shockwave Flash 10.1 r999.
Gnash 0.8.9, the GNU SWF Player. Copyright (C) 2006, 2007, 2008, 2009, 2010, 2011 Free Software Foundation, Inc.
Gnash comes with NO WARRANTY, to the extent permitted by law. You may redistribute copies of Gnash under the terms of the GNU General Public License. For more information about Gnash, see
Compatible Shockwave Flash 10.1 r999.

Steps to reproduce:

install firefox, gnash-common, gnash-gtk
open youtube an try to view a video.

on some sites i can read flash player is crashed
This task depends upon

Closed by  Jan Steffens (heftig)
Thursday, 11 October 2012, 20:57 GMT
Reason for closing:  Deferred
Comment by alex (kabolt) - Friday, 02 March 2012, 19:09 GMT
have you unchecked under gnash settings -> security:
1. connect only to localhost
2. connect only to local domain

These both options prevent of course that the youtube swf file can load the video (needs a connection to youtube).
Afterwards youtube worked for me.

An other, slightly more secure way would be to use the whitelist.
Comment by alex (kabolt) - Friday, 02 March 2012, 19:17 GMT
Disclaimer: I don't know if and how the whitelist works because I unchecked both options.
Comment by Federico Cinelli (Cinelli) - Thursday, 11 October 2012, 20:17 GMT
Make sure mms.cfg is setup correctly.

cat /etc/adobe/mms.cfg
#Hardware video decoding

If EnableLinuxHWVideoDecode=1 is uncommented it will crash browsers.