Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26444 - [e-svn] segfaults on strcmp in libc.so.6 when mounting usb drive

Attached to Project: Arch Linux
Opened by Andrew D. (andrewd18) - Friday, 14 October 2011, 14:27 GMT
Last edited by Allan McRae (Allan) - Saturday, 28 April 2012, 12:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Whenever I attempt to mount a USB drive, enlightenment crashes. I have verified this on USB drives with labels that have spaces and labels that don't, to make sure I'm not seeing Enlightenment bug #653 (http://trac.enlightenment.org/e/ticket/653).

Steps to reproduce:
1. Start enlightenment.
2. Connect USB flash drive to system.
3. E menu -> Files -> Home.
4. Select the heart for favorites menu. I see a USB drive icon named with the label of the drive, with a U icon in the corner.
5. Double-click the USB drive.

Expected Results:
* The drive should be mounted and I should see files.

Actual Results:
* Enlightenment segfaults.


GDB Output:

Program received signal SIGSEGV, Segmentation fault.
0x00007f9a49544946 in strcmp () from /lib/libc.so.6

#0 0x00007f9a49544946 in strcmp () from /lib/libc.so.6
#1 0x0000000000480cfc in e_fm2_client_data ()
#2 0x00000000004a83d8 in ?? ()
#3 0x00007f9a4c2ca3f2 in _ecore_event_call () from /usr/lib/libecore.so.1
#4 0x00007f9a4c2ce97e in ?? () from /usr/lib/libecore.so.1
#5 0x00007f9a4c2cef1f in ecore_main_loop_begin () from /usr/lib/libecore.so.1
#6 0x000000000042fea8 in main ()


Additional info:
* e-svn 62822-1
* glibc 2.14-6.1 installed from allan's repo, as I previously thought I might have bug #24615. I'd be happy to roll back and re-test if necessary.
* I do NOT have hal-git installed.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 28 April 2012, 12:13 GMT
Reason for closing:  No response
Comment by Dave Reisner (falconindy) - Friday, 14 October 2011, 19:39 GMT
Note that while the segfault happens in strcmp, the problem is that somewhere in e_fm2_client_data, a NULL is being passed to strcmp. This isn't an issue with glibc. You should run 'bt full' from the segfault in gdb and send it upstream.
Comment by Andrew D. (andrewd18) - Friday, 14 October 2011, 19:52 GMT
Thank you. :) I'll file this upstream once I rebuild it with debug symbols. Feel free to close this, then.
Comment by Ronald van Haren (pressh) - Sunday, 06 November 2011, 13:34 GMT
Is it fixed already in the new packages I just uploaded? If not can you link the upstream bug report here before I close this?

Loading...