Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26426 - Xorg does not start on MacBook Air 4,2: (EE) intel(0): Output eDP1 enabled but has no modes

Attached to Project: Arch Linux
Opened by Nico Schottelius (telmich) - Thursday, 13 October 2011, 14:40 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 08 January 2012, 20:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

This is a known bug in the current kernel, but I'm reporting it here, because all MacBook Air 4,2
users are probably affected:

Having xf86-video-intel 2.16.0-1 installed, I get the error message seen in the subject.
Full Xorg.log attached.

A workaround is to use fbdev, though:

[root@brief mac_hid]# cat /etc/X11/xorg.conf.d/20-fbdev.conf
Section "Device"
Driver "fbdev"
Identifier "card0"

EndSection

I see this problem on linux 3.0.6-2 as well as own my own compiled kernel
3.1.0-rc9-ARCH-00064-g65112dc, which is based on archs /proc/config.gz from 3.0.6.

Upstream information:

* https://bugs.freedesktop.org/show_bug.cgi?id=39533



Additional info:
* package version(s)
* config and/or log files etc.

* https://bbs.archlinux.org/viewtopic.php?id=123258

Steps to reproduce:

Type "startx"
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 08 January 2012, 20:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in testing/linux
Comment by Nico Schottelius (telmich) - Monday, 17 October 2011, 22:09 GMT
I've tried Keith's tree (git://people.freedesktop.org/~keithp/linux, fix-edp-vdd-power), the changes in their fix this problem.

Related mail on LKML: https://lkml.org/lkml/2011/10/17/448
Comment by Olivier (litemotiv) - Tuesday, 15 November 2011, 15:44 GMT
Nico, since you also have the other 4,2 patches incorporated, could i ask you for a precompiled package of your kernel?
Comment by Nico Schottelius (telmich) - Tuesday, 15 November 2011, 15:57 GMT
Sure, can do. I'll start the build in a few moments and will update this bug as soon as I've uploaded the package.
Comment by Olivier (litemotiv) - Saturday, 03 December 2011, 14:38 GMT
*ping* :-)
Comment by Bruno (brutasse) - Thursday, 05 January 2012, 14:48 GMT
This should be fixed in linux-3.2 since it integrates the tree mentioned by Nico. I'm running 3.2-rc7-mainline from AUR and it works fine on my MacBook Air 4,2. I initially encountered the issue with 3.1.
Comment by Olivier (litemotiv) - Thursday, 05 January 2012, 21:24 GMT
Confirmed, this bug is solved with linux-3.2

Loading...