Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26425 - FN-Key not working on MacBook Air 4,2, Trackpad only works with one mouse button

Attached to Project: Arch Linux
Opened by Nico Schottelius (telmich) - Thursday, 13 October 2011, 12:37 GMT
Last edited by Allan McRae (Allan) - Saturday, 02 June 2012, 12:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

FN+Cursor_UP does not make page-up, nor do any of the
special keys (fn+f1 = decrease brightness) show up.

Testing with xev, I see the exactly same keycodes coming back
with and without fn pressed.

I've seen this problem in https://bbs.archlinux.org/viewtopic.php?id=39726,
but do not see a reliable solution.

Blacklisting the usbhid module and loading it later on does also not fix this:
I've verified this by logging in via ssh, rmmod usbhid, modproble appletouch,
modprobe usbhid and everything (even after xorg restart) keeps the same.

Additional info:
* package version(s)
* config and/or log files etc.

I'm on linux 3.0.6-2 and have updated the system yesterday.

The main issue is that having no page-up does not allow me to scroll in
the terminal anymore, but I think the trackpad issue is related, thus added
it to the subject.

Steps to reproduce:
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 02 June 2012, 12:55 GMT
Reason for closing:  Fixed
Comment by Ionut Biru (wonder) - Thursday, 13 October 2011, 12:44 GMT
i wonder if this is related to  FS#26414 . Can you try that patch?
Comment by Nico Schottelius (telmich) - Thursday, 13 October 2011, 13:59 GMT
I've tried that patch without success. I also think this is not related, because fn-cursor_up also does *not* work in the console.

I suspect this is related/the same bug as discussed in the forum with ordering of modules, but somehow different (as this did not fix the issue here).
Comment by Ionut Biru (wonder) - Thursday, 13 October 2011, 14:01 GMT
try to downgrade some packages and point the exact faulty one.
Comment by Nico Schottelius (telmich) - Thursday, 13 October 2011, 14:10 GMT
I'm sorry, but this does not sounds very sane, as I don't have any working state on this devices nor do I know which ones to downgrade to which version.
Comment by Nico Schottelius (telmich) - Thursday, 13 October 2011, 19:06 GMT
Update:

To get the mouse correctly working, the following procedure helps:

[root@brief ~]# rmmod usbhid; rmmod bcm5974; sleep 3; modprobe bcm5974; sleep 1; modprobe usbhid;

It probably also works without the sleeps, which I inserted to ensure the previous driver initialised correctly.

It does *not* fix the fn-key issue, though.
Comment by Nico Schottelius (telmich) - Monday, 17 October 2011, 22:12 GMT
Another great news, there is a fix available in Jiri's for-next branch (http://git.kernel.org/?p=linux/kernel/git/jikos/hid.git;a=summary), which I've tested and works great.

Related mail on LKML: https://lkml.org/lkml/2011/10/17/326
Comment by Jelle van der Waa (jelly) - Saturday, 28 January 2012, 11:10 GMT
Is that merged in the kernel yet?
Comment by Nico Schottelius (telmich) - Monday, 30 January 2012, 12:53 GMT
Fixed in 3.2.0-rc7 and probably all later versions as well.

Loading...