Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26416 - [linux] regression - powertop 2 doesn't work anymore after 3.0.4 -> 3.0.6 update

Attached to Project: Arch Linux
Opened by Kev (Kev) - Wednesday, 12 October 2011, 17:12 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 29 October 2011, 06:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


After upgrading the kernel from 3.0.4 to 3.0.6 on archlinux powertop2 is not able to get the current discharge rate (watt). I guess some confing option in the kernel config file has been changed.

Additional info:
* package version(s)
working: <= linux-3.0.4-1
not working: linux 3.0.6-1 and 3.0.6-1

Steps to reproduce:

Install Powertop 1.98-1 ( on an acpi working laptop with linux-3.0.4-1 and run "sudo powertop" while the laptop is discharging the battery -> it will show you the current watts discharging.
Upgrade to linux 3.0.6-1/2 and reboot.
Run "sudo powertop" -> the information about the power consume (watt) is missing.

This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 29 October 2011, 06:38 GMT
Reason for closing:  Won't fix
Comment by Giesi (giesi) - Wednesday, 12 October 2011, 22:55 GMT
A function in older kernels was declared as deprecated -> since 3.0.6 it's deleted! Many programs have problems with this (pm-utils / xfce4-power-manager / ...)
Comment by Kev (Kev) - Wednesday, 12 October 2011, 23:55 GMT
How crazy is that?
Why do they remove a function in a bugfix (minor) release?!
Do you have a git commit link?
Comment by Jan de Groot (JGC) - Thursday, 13 October 2011, 17:30 GMT
It's not crazy at all. We already decided to remove this for 2.6.39, but somehow we missed that.
Face it: /proc/acpi/battery is deprecated upstream since 2.6.24. Software that hasn't adapted to the sysfs interface should get fixed instead of adding old shit back to the kernel.

There has been some effort from a gentoo dev to add sysfs support to powertop, but nobody ever looked at his patch, resulting in the current broken behaviour:
Comment by ValdikSS (ValdikSS) - Wednesday, 19 October 2011, 10:51 GMT
I hope this option would be re-enabled in next kernel.
Comment by Tobias Powalowski (tpowa) - Saturday, 29 October 2011, 06:38 GMT
Software needs to adopt to the kernel and not the other way around!