Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26408 - [xkeyboard-config] gnome-terminal is broken with 2.4.1-1

Attached to Project: Arch Linux
Opened by Vasily Khoruzhick (anarsoul) - Wednesday, 12 October 2011, 08:42 GMT
Last edited by Jan de Groot (JGC) - Friday, 09 November 2012, 14:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:

Makes gnome-terminal behave strangely, on F10 it opens context menu (one which appears on right mouse click), but F10 shortcut is disabled in gnome-terminal (and anyway, it opens another menu when F10 shortcut is enabled)

Additional info:
* package version(s)

2.4.1-1

* config and/or log files etc.


Steps to reproduce:

Launch gnome-terminal, disable F10 shortcut, press F10.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 09 November 2012, 14:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in GNOME 3.6 and latest xkeyboard-config.
Comment by Sergej Pupykin (sergej) - Wednesday, 12 October 2011, 13:38 GMT
xterm and urxvt don't recognize Shift+Fn keys. Found report (http://www.gossamer-threads.com/lists/gentoo/amd64/240271) that looks the same.
Comment by Sergej Pupykin (sergej) - Wednesday, 12 October 2011, 13:44 GMT Comment by Sergej Pupykin (sergej) - Wednesday, 12 October 2011, 13:48 GMT
I can confirm that this is the fix. I applied it in place (/usr/share/X11/xkb) with 'patch -p1' command and Shift+Fn works now.

@Vasily please try it too.
Comment by Vasily Khoruzhick (anarsoul) - Wednesday, 12 October 2011, 13:50 GMT
Already tried, this patch does not fix gnome-terminal issue.
Comment by Sergej Pupykin (sergej) - Wednesday, 12 October 2011, 14:16 GMT
Ok, I've added new bug  FS#26414  for Shift+Fn.
Comment by Vasily Khoruzhick (anarsoul) - Thursday, 13 October 2011, 13:49 GMT
It's not only gnome-terminal, looks like any app is affected: by default, popup menu should be opened on shift+f10, but with xkeyboard-config-2.4.1 it's opened on f10, reproducible in chromium
Comment by Ilmari Repo (netspider) - Wednesday, 26 October 2011, 22:18 GMT
It seems that this affects also other GTK based apps in addition to gnome-terminal and chromium. At least transmission-gtk shows changed behaviour when pressing F10.
Newest git version of xkeyboard-config has same issue.

I tested different older revisions and F10 seems to first break after this commit http://cgit.freedesktop.org/xkeyboard-config/commit/?id=062b5bfcc59f9f6e4e11ba394bbe459af2a07b7e
Comment by Thomas Wouters (twouters) - Thursday, 17 November 2011, 07:16 GMT
I've been able to work around this. https://bbs.archlinux.org/viewtopic.php?id=129872
It's probably not the best solution, but as far as I can tell it's the only one around :p
Comment by Greg (dolby) - Monday, 15 October 2012, 02:41 GMT
Is there a freedesktop.org bug report for this?
Comment by Vasily Khoruzhick (anarsoul) - Monday, 15 October 2012, 12:34 GMT

Loading...