Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26405 - [mdadm] 3.2.2-4 update: /dev/disk/by-label/* symlinks no longer created for md devices.

Attached to Project: Arch Linux
Opened by Steve Vialle (steve_v) - Wednesday, 12 October 2011, 06:21 GMT
Last edited by Ionut Biru (wonder) - Friday, 14 October 2011, 11:21 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Decompressing Linux ..Parsing ELF...done
Booting the kernel..
...Starting udevd
done
....Running Hook [udev]
...Triggering uevents...done
....Running Hook [mdadm]
mdadm.../dev/md/1 has been started with 2 drives
mdadm.../dev/md/3 has been started with 5 drives
Waiting 10 seconds for /dev/disk/by-label/Root
Root device /dev/disk/by-label/Root doesn't exist...attempting to create it
Error unable to determine major-minor number of root device /dev/disk/by-label/Root


Additional info:
The md devices are being assembled correctly, but no uuid or label symlinks are created:

ramfs#: ls -l /dev/disk/by-label

lrwxrwxrwx 1 root root 10 Oct 13 2011 Boot -> ../../sda1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Boot_Backup -> ../../sdb1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Games -> ../../sdd1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Swap -> ../../sdd2
lrwxrwxrwx 1 root root 10 Oct 13 2011 System\x20Reserved -> ../../sdc1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Win7 -> ../../sdc2

ramfs#: ls -l /dev/md

lrwxrwxrwx 1 root root 6 Oct 13 2011 1 -> ../md1
lrwxrwxrwx 1 root root 6 Oct 13 2011 3 -> ../md3

Modifying the kernel command line to 'root=/dev/md/1' allows a normal boot, after which all symlinks show up as expected

steve@Damnation ~> ls -l /dev/disk/by-label/

lrwxrwxrwx 1 root root 9 Oct 13 2011 Archive -> ../../md3
lrwxrwxrwx 1 root root 10 Oct 13 2011 Boot -> ../../sda1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Boot_Backup -> ../../sdb1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Games -> ../../sdd1
lrwxrwxrwx 1 root root 9 Oct 13 2011 Root -> ../../md1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Swap -> ../../sdd2
lrwxrwxrwx 1 root root 10 Oct 13 2011 System\x20Reserved -> ../../sdc1
lrwxrwxrwx 1 root root 10 Oct 13 2011 Win7 -> ../../sdc2


Steps to reproduce:
Boot with root=/dev/disk/by-label/[ROOTLABEL] where ROOTLABEL refers to an md device.
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 14 October 2011, 11:21 GMT
Reason for closing:  Not a bug
Comment by Thomas Bächler (brain0) - Wednesday, 12 October 2011, 20:42 GMT
This is due to a change in mdadm. The 'mdadm_udev' hook does auto-assembly and contains all necessary udev rules. The 'mdadm' hook does manual assembly and contains no udev rules.

Loading...