Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26391 - [transmission-gtk]segfault on start

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Tuesday, 11 October 2011, 08:23 GMT
Last edited by Ionut Biru (wonder) - Sunday, 23 October 2011, 18:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After updating transmission-gtk and transmission-cli to 2.41 transmission-gtk fails to start with a segmentation fault. transmission-daemon can be started and you can connect to it via web interface, but the download/upload list is empty. Starting transmission-gtk with empty .config and .cache dirs works, but adding a torrent produces a segfault again with following error in /var/log/messages.log (thanks nemesis2all):

Oct 10 22:11:53 arch kernel: [15012.658399] transmission-gt[13905]: segfault at 20 ip 00007fac2b4aecb8 sp 00007fffe7e37280 error 6 in libglib-2.0.so.0.3000.0[7fac2b494000+f3000]

Reverting to 2.33-1 fixes the problem (thanks dcc24).

See also https://bbs.archlinux.org/viewtopic.php?id=128076

Additional info:
* package version: 2.41-1 and 2.41-2 both affected

Steps to reproduce:
* update to 2.41 and start transmission-gtk
This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 23 October 2011, 18:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  transmission 2.42
Comment by Ionut Biru (wonder) - Tuesday, 11 October 2011, 09:12 GMT
Comment by Michael Kogan (Photon) - Tuesday, 11 October 2011, 11:41 GMT
I hope, this is correct:

Starting program: /usr/bin/transmission-gtk
[Thread debugging using libthread_db enabled]
[New Thread 0xb6bdbb70 (LWP 26801)]
[New Thread 0xb63dab70 (LWP 26802)]
[New Thread 0xb5bd9b70 (LWP 26803)]
[New Thread 0xb53d8b70 (LWP 26804)]

Program received signal SIGSEGV, Segmentation fault.
Comment by Ionut Biru (wonder) - Tuesday, 11 October 2011, 11:44 GMT
then run bt full
Comment by Michael Kogan (Photon) - Tuesday, 11 October 2011, 11:47 GMT
Sorry, here it goes.
Comment by Ionut Biru (wonder) - Tuesday, 11 October 2011, 11:52 GMT
recompile glib2 as well and do it again. also what version of glib2 do you have?
Comment by Michael Kogan (Photon) - Tuesday, 11 October 2011, 12:06 GMT
1 core/glib2 2.30.0-1 [installed]

New trace attached.
Comment by Ionut Biru (wonder) - Tuesday, 11 October 2011, 12:07 GMT
now this trace report it to transmission bugtracker and post the link here
Comment by Michael Kogan (Photon) - Tuesday, 11 October 2011, 12:19 GMT
Oh, well... Is it a Gtk+ client bug or a daemon bug?
Comment by Ionut Biru (wonder) - Tuesday, 11 October 2011, 12:20 GMT
i guess gtk client
Comment by Michael Kogan (Photon) - Tuesday, 11 October 2011, 12:35 GMT
Bug reported and awaits moderation (at least I hope so :)).

edit: Here is the report: https://trac.transmissionbt.com/ticket/4554
Comment by Michael Kogan (Photon) - Wednesday, 12 October 2011, 10:57 GMT
Bug is fixed with the recent SVN revisions.
Comment by Ionut Biru (wonder) - Wednesday, 12 October 2011, 11:30 GMT
don't try svn. try to apply https://trac.transmissionbt.com/changeset/12973 to our current version and let me know if is fixed
Comment by Michael Kogan (Photon) - Wednesday, 12 October 2011, 12:26 GMT
Unfortunately not. The fix will be backported to 2.4x though, I just don't know when.

edit: I asked about it in a comment to the upstream bug report.
Comment by Zhehao Mao (zhehao) - Sunday, 16 October 2011, 02:15 GMT
It's not just GTK, I tested it with the transmission-cli and it still segfaults.

Loading...