Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26381 - [Synergy] bug: Cursor trapped under GNOME 3 (gnome-shell)

Attached to Project: Community Packages
Opened by none given (hoban) - Monday, 10 October 2011, 16:52 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 27 February 2013, 18:58 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When logged in to a GNOME 3 desktop, the synergy connection is happening and it is maintaining a channel. However, the mouse isn't being released from the desktop unless certain windows are tiled against the side of the screen.

Additional info:
* package version(s)
synergy-1.3.7-1

Steps to reproduce:
1. Configure synergy server on Linux under gnome 2.x or kde and another synergy client (my case client os OS X) so that it's working well.
2. Log into gnome 3 with gnome-shell
3. Verify that synergy server is running and that client connects with no issues.

Expected: synergy to continue working as it does under all other desktop environments
Actual: synergy is broken even though client and server are configured correctly

Note: Please see the upstream bug I created a few months ago: http://synergy-foss.org/tracker/issues/2958

I've attached an updated PKGBUILD with a proposed fix which solved the issue for me but possibly has unintended side-effects (again, see the upstream bug report).

Thanks!
   PKGBUILD (1.4 KiB)
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 27 February 2013, 18:58 GMT
Reason for closing:  Upstream
Comment by Jelle van der Waa (jelly) - Monday, 17 October 2011, 08:27 GMT
I cant test it here, since i dont have gnome shell running. If the patch is accepted upstream i might add it
Comment by Jelle van der Waa (jelly) - Tuesday, 14 August 2012, 10:45 GMT
Can you update to 1.4.10 and see if it's fixed?
Comment by Simon Perry (pezz) - Sunday, 07 October 2012, 02:29 GMT
I just hit this issue today when trying to use synergy after not using it for a while.

Using 1.4.10, I've found that it works when the GNOME 3 box is the server -- if it is the client, the mouse doesn't move to the other box.

Pretty easy workaround I suppose, so not sure what you want to do with this bug, but thought I'd throw a comment in anyway.

Cheers.
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 27 February 2013, 18:57 GMT
I'm sorry but this is most definitely an upstream problem and since upstream also is responsive enough, we don't need to patch this downstream. Please pursue this issue upstream and only reopen if upstream is being uncooperative for whatever reason.

Loading...