Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26324 - [tomboy] slowed session logout

Attached to Project: Arch Linux
Opened by GutsBlack (GutsBlack) - Friday, 07 October 2011, 07:20 GMT
Last edited by Jan Steffens (heftig) - Saturday, 27 September 2014, 20:51 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Isenmann Daniel (ise)
Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No



Additional info:
* package version(s)
tomboy 1.8.0-1

* config and/or log files etc.

Steps to reproduce:
Tomboy installed and started. The logout take 60 secondes in Gnome 3.2.
This task depends upon

Closed by  Jan Steffens (heftig)
Saturday, 27 September 2014, 20:51 GMT
Reason for closing:  No response
Comment by John (PTBM133A4X) - Wednesday, 02 November 2011, 23:43 GMT
I can also confirm that having Tomboy notes running, slows the logout quite a lot on Gnome Shell. I have to remember to quit Tomboy before trying to switch off my computer. Thank you.
Comment by Hermann Zahnweh (eigengrau) - Friday, 08 June 2012, 23:06 GMT
  • Field changed: Percent Complete (100% → 0%)
Can't comment on closed bugs, I guess. Maybe you could provide interested parties with the information that this bug is due to dbus-sharp. It's fixed in git, but the supported dbus-sharp is build from outdated tarballs. dbus-sharp-git from the AUR fixes the issue.
Comment by Isenmann Daniel (ise) - Saturday, 09 June 2012, 10:00 GMT
@Ionut: I will have a look at dbus-sharp. Maybe I will merge some fixes from the git version to our package.
Comment by Ingo Albrecht (indigo) - Friday, 31 August 2012, 16:01 GMT
I can also confirm the bug, but don't really want to install dbus from AUR for that at current.
The Wheezy I want tomboy to sync with does not exhibit the bug.

Versions at time of writing:
tomboy Wheezy 1.10.0 (Arch 1.10.2)
libdbus Wheezy 0.7.0-5 (Arch 0.7.0-4)
libdbus-glib Wheezy 0.5.0-4 (Arch 0.5.0-4)

Disabling syncronisation in tomboy or syncing right before logout makes no difference.
edit: Have been using Gnote for ages now. It proves great as a replacement.
Comment by Pavel (Alsvartr) - Friday, 04 January 2013, 00:49 GMT
Any progress on this?
Comment by Isenmann Daniel (ise) - Tuesday, 11 June 2013, 20:58 GMT
Does the error still appears with the newest version from the repo?
Comment by John (PTBM133A4X) - Monday, 17 June 2013, 23:36 GMT
I'm still experiencing this problem with latest updates using yaourt.
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 13 March 2014, 00:43 GMT
status? upstream report?