Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26296 - [squid] after clean cache not create new cache, mistake in squid.conf..

Attached to Project: Arch Linux
Opened by Nevyansk (gardarea51) - Thursday, 06 October 2011, 11:17 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 29 August 2012, 12:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Kevin Piche (kpiche)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello!
Today I clean squid cache:
/etc/rc.d/squid stop
rm -r /var/cache/squid/*

and starting squid (/etc/rc.d/squid start OR squid -z && /etc/rc.d/squid start). Squid not create new cache directories and file swap.state, because in squid.conf not found description cache_dir, but squid working, but directory /var/cache/squid/ has been clean.

Additional info:
* package version(s)
pacman -Qi squid
Название : squid
Версия : 3.1.14-2
URL : http://www.squid-cache.org
Лицензии : GPL
Группы : Нет
Предоставляет : Нет
Зависит от : openssl pam cron perl libtool
Дополнительно : Нет
Требуется пакетами : dansguardian
Конфликтует с : Нет
Заменяет : Нет
Размер установленного : 9972,00 K
Сборщик : Eric Belanger <eric@archlinux.org>
Архитектура : i686
Дата сборки : Вс. 21 авг. 2011 10:46:02
Дата установки : Чт. 06 окт. 2011 16:04:48
Причина установки : Явно установлен
Установочный скрипт : Yes
Описание : A full-featured Web proxy cache server.


Steps to reproduce:

I added in /etc/squid.conf: cache_dir ufs /var/cache/squid 100 16 256
And after this i start /etc/rc.d/squid start and it running squid -z before starting squid (see script /etc/rc.d/squid, section start). Cache has been created. I think "cache_dir" definition should be added to squid.conf by default, that people have no problems.

Sorry for my bad english, with respect. =)
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 29 August 2012, 12:50 GMT
Reason for closing:  Won't fix
Additional comments about closing:  squid is now in AUR
Comment by Jelle van der Waa (jelly) - Wednesday, 08 August 2012, 18:04 GMT
Nope this is not a mistake, it's the default squid.conf we ship from upstream. You will have to configure the amount of cache size yourself, since it depends per system how much you would like to use.

Loading...