Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26245 - [firefox] creates additional shortcuts if set as default

Attached to Project: Arch Linux
Opened by Reda Lazri (rAX) - Tuesday, 04 October 2011, 13:40 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 11 December 2012, 15:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

If I set Firefox(and Thunderbird) as a default browser it creates additional shortcuts.

Additional info:
* package version(s): Happened with 6.0 and 7.0
* config and/or log files etc.


Steps to reproduce:
Just set Firefox as a default browser when it asks you and look in ~/.local/share/applications or in you 'default applications' interface of choice.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 11 December 2012, 15:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in svn trunk. With the speed firefox updates are released, this should be fixed very soon in a released package.
Comment by Ionut Biru (wonder) - Tuesday, 04 October 2011, 13:46 GMT
so don't answer "yes" and use the one already provided by our package
Comment by Reda Lazri (rAX) - Tuesday, 04 October 2011, 13:53 GMT
That is not about me answering 'yes' or not, Firefox should not create a shortcut. Also, what package?
Comment by Ionut Biru (wonder) - Tuesday, 04 October 2011, 13:55 GMT
the Firefox entry from that list with an icon is there because of our /usr/share/applications/firefox.desktop presented in our firefox package.

just delete the one created automatically by firefox in ~/.local/share/applications
Comment by Reda Lazri (rAX) - Tuesday, 04 October 2011, 14:17 GMT
That's exactly why I'm reporting this as a bug. I deleted the shortcuts and used the one with the icon, but Firefox always asks to be default despite the fact that I already selected it as default :). If I answer 'yes' it creates a shortcut again.
Comment by Ionut Biru (wonder) - Tuesday, 04 October 2011, 14:21 GMT
when you see that message, there is a checkbox and you uncheck it and this will disable that crap.
you can also do this by opening preferences->advanced, general tab, uncheck Always check to see if Firefox is the default browser

you can also report this upstream to do the check more intelligent if a .desktop is already provided by distributions or ask to include one by default, without generating one locally
Comment by Reda Lazri (rAX) - Tuesday, 04 October 2011, 14:28 GMT
Yes, I know these workarounds :D. Well I reported because I thought this was a packaging problem(Never happened on Ubuntu before). Now, since it's problem with Firefox itself, I don't think I should be bothering you :)
Comment by Greg (dolby) - Monday, 15 October 2012, 08:24 GMT
Does this happen with firefox 16.0.1?
Comment by Reda Lazri (rAX) - Monday, 15 October 2012, 10:26 GMT
Yep. :(
Comment by Ionut Biru (wonder) - Monday, 15 October 2012, 13:46 GMT
we won't have a fix for this until mozilla provides a proper desktop file. right now when you marked it as default it generates a desktop file in ~/local/share/applications.
Comment by Reda Lazri (rAX) - Monday, 15 October 2012, 13:53 GMT
Yes, I understand. No worries. :) I don't "mark as default" anymore. I only did it to answer the question.
Comment by Greg (dolby) - Saturday, 17 November 2012, 06:31 GMT
@rAX: has this been reported to the mozilla developers?
Comment by Reda Lazri (rAX) - Saturday, 17 November 2012, 12:17 GMT Comment by Jan de Groot (JGC) - Thursday, 29 November 2012, 10:16 GMT
Could you test if changing Exec=firefox to Exec=/usr/lib/firefox/firefox in /usr/share/applications/firefox.desktop fixes this issue? The desktop file installed by firefox itself uses that for Exec=.
Comment by Reda Lazri (rAX) - Thursday, 29 November 2012, 12:41 GMT
Yes, it does fix the problem. :)

Loading...