Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#26232 - [mingw32-gcc] cannot find entry symbol nable-stdcall-fixup

Attached to Project: Community Packages
Opened by m0rph (m0rph) - Monday, 03 October 2011, 20:16 GMT
Last edited by Sergej Pupykin (sergej) - Wednesday, 05 October 2011, 16:16 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When I'm building my program (crosscompile Qt application in Linux for Windows), I got linker error message:
/usr/lib/gcc/i486-mingw32/4.6.1/../../../../i486-mingw32/bin/ld: warning: cannot find entry symbol nable-stdcall-fixup; defaulting to 0000000000401000
Maybe I'm wrong, and this bug is related to aur/mingw32-qt.

Additional info:
* package version(s)
mingw32-gcc-4.6.1-1 (downgrading to mingw32-gcc-4.5.2-4 solves problem)

* config and/or log files etc.

Steps to reproduce:
You need to have aur/mingw32-qt installed.
Just create simple "hello-world" source file like this:

#include <iostream>

int main()
std::cout << "Hello, world!" << std::endl;
return 0;

Save it in a main.cpp file for example and exec three commands:
i486-mingw32-qmake -project
This task depends upon

Closed by  Sergej Pupykin (sergej)
Wednesday, 05 October 2011, 16:16 GMT
Reason for closing:  Not a bug
Additional comments about closing:  should be fixed in mingw32-qt
Comment by Sergej Pupykin (sergej) - Monday, 03 October 2011, 21:23 GMT
Not sure what is the issue, but test can be compiled without warnings with:

i486-mingw32-g++ main.c -o main.exe

and then it runs under wine

$ cp /usr/i486-mingw32/bin/libstdc++-6.dll .
$ cp /usr/i486-mingw32/lib/libgcc_s_sjlj-1.dll .
$ wine main.exe
Hello, world!
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 04 October 2011, 01:50 GMT
The problem is that mingw32-qt does not compile qt using our mingw32 but it uses pre-compiled libs by Qt which are compiled with a different version of mingw32. mingw32-qt should be fixed to compile from source instead. This is not a bug by us. I suggest the ticket be closed as invalid.
Comment by Alexandre Bique (babali) - Tuesday, 04 October 2011, 10:44 GMT
yes we should build mingw32-qt from source.