Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26208 - [transcode] error at end of pass 1 when called from dvdrip

Attached to Project: Arch Linux
Opened by Fabien COUTANT (fcoutant) - Sunday, 02 October 2011, 19:19 GMT
Last edited by Eric Belanger (Snowman) - Thursday, 12 September 2013, 20:46 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Trying to make rips from TV-records on DVD-R with dvdrip.
My old install (glibc 2.13-5, ffmpeg 25679-1, transcode 1.1.5-5) was working fine.
This new, fresh install does not: it throws an error at the end of pass 1


Additional info:
* package version(s)
glibc 2.14-6
ffmpeg 20110923-1
transcode 1.1.5-6
* config and/or log files etc.
dvdrip's logfile.txt:
...
Executing command: mkdir -m 0775 -p '/mnt/rip/XXX/tmp' && cd /mnt/rip/XXX/tmp && mkdir -p /mnt/rip/XXX/avi/001 && execflow -n 19 transcode -H 10 -a 0 -x vob,null -i \/mnt\/rip\/XXX\/vob\/001\/ -w 945,50 -c 1-144326 -L 0 -F mpeg4 -b 64,0,2 -s 2.487 --a52_drc_off -f 25.000 -Y 0,4,0,4 -B 30,15,8 -R 1 -y ffmpeg,null -o /dev/null --progress_meter 2 --progress_rate 25 && echo EXECFLOW_OK
...
*** glibc detected *** transcode: munmap_chunk(): invalid pointer: 0xa5596f08 ***
======= Backtrace: =========
/lib/libc.so.6(+0x6e5f2)[0xb762b5f2]
/lib/libc.so.6(+0x6e838)[0xb762b838]
/usr/lib/libavutil.so.50(av_freep+0x12)[0xa4942592]
/usr/lib/libavutil.so.50(av_opt_free+0x3c)[0xa4944f3c]
/usr/lib/libavcodec.so.52(avcodec_close+0xcb)[0xa4a540e9]
/usr/lib/transcode/export_ffmpeg.so(tc_export+0x562)[0xa5592c62]
transcode(tcv_export+0x62)[0x805b5b2]
transcode(tc_encoder_stop+0xae)[0x805cb4e]
transcode(main+0x4115)[0x8053205]
/lib/libc.so.6(__libc_start_main+0xf3)[0xb75d6223]
transcode[0x80544f5]
======= Memory map: ========
08048000-080a4000 r-xp 00000000 fe:01 57142 /usr/bin/transcode
080a4000-080a5000 r--p 0005b000 fe:01 57142 /usr/bin/transcode
080a5000-080a7000 rw-p 0005c000 fe:01 57142 /usr/bin/transcode
080a7000-080be000 rw-p 00000000 00:00 0
08fbf000-0906d000 rw-p 00000000 00:00 0 [heap]
a185d000-a185e000 rw-p 00000000 00:00 0
a18d0000-a18d1000 rw-p 00000000 00:00 0
a19c3000-a19c4000 ---p 00000000 00:00 0
a19c4000-a21c4000 rw-p 00000000 00:00 0
a21c4000-a21c5000 ---p 00000000 00:00 0
a21c5000-a29c5000 rw-p 00000000 00:00 0
a29c5000-a29c6000 ---p 00000000 00:00 0
a29c6000-a31c6000 rw-p 00000000 00:00 0
a31c6000-a31c7000 ---p 00000000 00:00 0
a31c7000-a39c7000 rw-p 00000000 00:00 0
a39c7000-a39c8000 ---p 00000000 00:00 0
a39c8000-a41c8000 rw-p 00000000 00:00 0
a41c8000-a41e4000 r-xp 00000000 fe:01 28018 /usr/lib/libgcc_s.so.1
a41e4000-a41e5000 rw-p 0001b000 fe:01 28018 /usr/lib/libgcc_s.so.1
a41e5000-a42c8000 r-xp 00000000 fe:01 2670 /usr/lib/libstdc++.so.6.0.16
a42c8000-a42cc000 r--p 000e2000 fe:01 2670 /usr/lib/libstdc++.so.6.0.16
a42cc000-a42cd000 rw-p 000e6000 fe:01 2670 /usr/lib/libstdc++.so.6.0.16
a42cd000-a42d4000 rw-p 00000000 00:00 0
a42d4000-a435a000 r-xp 00000000 fe:01 24932 /usr/lib/liborc-0.4.so.0.14.0
a435a000-a435e000 rw-p 00085000 fe:01 24932 /usr/lib/liborc-0.4.so.0.14.0
a435e000-a4389000 r-xp 00000000 fe:01 24925 /usr/lib/libopencore-amrnb.so.0.0.2
a4389000-a438a000 rw-p 0002b000 fe:01 24925 /usr/lib/libopencore-amrnb.so.0.0.2
a438a000-a439e000 r-xp 00000000 fe:01 24927 /usr/lib/libopencore-amrwb.so.0.0.2
a439e000-a439f000 rw-p 00013000 fe:01 24927 /usr/lib/libopencore-amrwb.so.0.0.2
a439f000-a43be000 r-xp 00000000 fe:01 24929 /usr/lib/libopenjpeg.so.1.4.0
a43be000-a43bf000 r--p 0001e000 fe:01 24929 /usr/lib/libopenjpeg.so.1.4.0
a43bf000-a43c0000 rw-p 0001f000 fe:01 24929 /usr/lib/libopenjpeg.so.1.4.0
a43c0000-a4471000 r-xp 00000000 fe:01 154279 /usr/lib/libschroedinger-1.0.so.0.10.0
a4471000-a4474000 rw-p 000b0000 fe:01 154279 /usr/lib/libschroedinger-1.0.so.0.10.0
a4474000-a448f000 r-xp 00000000 fe:01 25081 /usr/lib/libtheoradec.so.1.1.4
a448f000-a4490000 r--p 0001a000 fe:01 25081 /usr/lib/libtheoradec.so.1.1.4
a4490000-a4491000 rw-p 0001b000 fe:01 25081 /usr/lib/libtheoradec.so.1.1.4
a4491000-a44d0000 r-xp 00000000 fe:01 25082 /usr/lib/libtheoraenc.so.1.1.2
a44d0000-a44d1000 ---p 0003f000 fe:01 25082 /usr/lib/libtheoraenc.so.1.1.2
a44d1000-a44d2000 r--p 0003f000 fe:01 25082 /usr/lib/libtheoraenc.so.1.1.2
a44d2000-a44d3000 rw-p 00040000 fe:01 25082 /usr/lib/libtheoraenc.so.1.1.2
a44d3000-a44f8000 r-xp 00000000 fe:01 23933 /usr/lib/libvorbis.so.0.4.5
a44f8000-a44f9000 rw-p 00025000 fe:01 23933 /usr/lib/libvorbis.so.0.4.5
a44f9000-a465e000 r-xp 00000000 fe:01 23242 /usr/lib/libvorbisenc.so.2.0.8
a465e000-a466f000 rw-p 00165000 fe:01 23242 /usr/lib/libvorbisenc.so.2.0.8
a466f000-a4708000 r-xp 00000000 fe:01 28550 /usr/lib/libvpx.so.0.9.7
a4708000-a470a000 rw-p 00098000 fe:01 28550 /usr/lib/libvpx.so.0.9.7
a470a000-a4714000 rw-p 00000000 00:00 0
a4714000-a47cd000 r-xp 00000000 fe:01 28567 /usr/lib/libx264.so.115
a47cd000-a47ce000 rw-p 000b9000 fe:01 28567 /usr/lib/libx264.so.115
a47ce000-a47eb000 rw-p 00000000 00:00 0
a47eb000-a4896000 r-xp 00000000 fe:01 15408 /usr/lib/libxvidcore.so.4.3
a4896000-a48a1000 rw-p 000aa000 fe:01 15408 /usr/lib/libxvidcore.so.4.3
a48a1000-a490a000 rw-p 00000000 00:00 0
a490a000-a491c000 r-xp 00000000 fe:01 28542 /usr/lib/libva.so.1.0.14
a491c000-a491d000 rw-p 00011000 fe:01 28542 /usr/lib/libva.so.1.0.14
a491d000-a4935000 rw-p 00000000 00:00 0
a4935000-a4952000 r-xp 00000000 fe:01 174974 /usr/lib/libavutil.so.50.43.0
a4952000-a4953000 r--p 0001c000 fe:01 174974 /usr/lib/libavutil.so.50.43.0
a4953000-a4954000 rw-p 0001d000 fe:01 174974 /usr/lib/libavutil.so.50.43.0
a4954000-a4957000 rw-p 00000000 00:00 0
a4957000-a4995000 r-xp 00000000 fe:01 102973 /usr/lib/libmp3lame.so.0.0.0
a4995000-a4997000 rw-p 0003d000 fe:01 102973 /usr/lib/libmp3lame.so.0.0.0
a4997000-a49ca000 rw-p 00000000 00:00 0
a49ca000-a4ff3000 r-xp 00000000 fe:01 174960 /usr/lib/libavcodec.so.52.122.0
a4ff3000-a4ff4000 r--p 00628000 fe:01 174960 /usr/lib/libavcodec.so.52.122.0
a4ff4000-a5000000 rw-p 00629000 fe:01 174960 /usr/lib/libavcodec.so.52.122.0
a5000000-a5553000 rw-p 00000000 00:00 0
a556b000-a5581000 r-xp 00000000 fe:01 28582 /usr/lib/libz.so.1.2.5
a5581000-a5582000 r--p 00015000 fe:01 28582 /usr/lib/libz.so.1.2.5
a5582000-a5583000 rw-p 00016000 fe:01 28582 /usr/lib/libz.so.1.2.5
a5583000-a558a000 r-xp 00000000 fe:01 6934 /lib/librt-2.14.so
a558a000-a558b000 r--p 00006000 fe:01 6934 /lib/librt-2.14.so
a558b000-a558c000 rw-p 00007000 fe:01 6934 /lib/librt-2.14.so
a558c000-a5598000 r-xp 00000000 fe:01 45725 /usr/lib/transcode/export_ffmpeg.so
a5598000-a5599000 r--p 0000b000 fe:01 45725 /usr/lib/transcode/export_ffmpeg.so
a5599000-a559a000 rw-p 0000c000 fe:01 45725 /usr/lib/transcode/export_ffmpeg.so
a559a000-b75bd000 rw-p 00000000 00:00 0
b75bd000-b771f000 r-xp 00000000 fe:01 2440 /lib/libc-2.14.so
b771f000-b7720000 ---p 00162000 fe:01 2440 /lib/libc-2.14.so
b7720000-b7722000 r--p 00162000 fe:01 2440 /lib/libc-2.14.so
b7722000-b7723000 rw-p 00164000 fe:01 2440 /lib/libc-2.14.so
b7723000-b7726000 rw-p 00000000 00:00 0
b7726000-b7729000 r-xp 00000000 fe:01 1544 /lib/libdl-2.14.so
b7729000-b772a000 r--p 00002000 fe:01 1544 /lib/libdl-2.14.so
b772a000-b772b000 rw-p 00003000 fe:01 1544 /lib/libdl-2.14.so
b772b000-b7753000 r-xp 00000000 fe:01 1545 /lib/libm-2.14.so
b7753000-b7754000 r--p 00027000 fe:01 1545 /lib/libm-2.14.so
b7754000-b7755000 rw-p 00028000 fe:01 1545 /lib/libm-2.14.so
b7755000-b776c000 r-xp 00000000 fe:01 6932 /lib/libpthread-2.14.so
b776c000-b776d000 r--p 00016000 fe:01 6932 /lib/libpthread-2.14.so
b776d000-b776e000 rw-p 00017000 fe:01 6932 /lib/libpthread-2.14.so
b776e000-b7771000 rw-p 00000000 00:00 0
b7771000-b7777000 r-xp 00000000 fe:01 28328 /usr/lib/libogg.so.0.8.0
b7777000-b7778000 rw-p 00005000 fe:01 28328 /usr/lib/libogg.so.0.8.0
b7778000-b7779000 r-xp 00000000 fe:01 45754 /usr/lib/transcode/export_null.so
b7779000-b777a000 r--p 00000000 fe:01 45754 /usr/lib/transcode/export_null.so
b777a000-b777b000 rw-p 00001000 fe:01 45754 /usr/lib/transcode/export_null.so
b777b000-b7782000 r-xp 00000000 fe:01 45761 /usr/lib/transcode/import_vob.so
b7782000-b7783000 r--p 00006000 fe:01 45761 /usr/lib/transcode/import_vob.so
b7783000-b7784000 rw-p 00007000 fe:01 45761 /usr/lib/transcode/import_vob.so
b7784000-b7785000 rw-p 00000000 00:00 0
b7785000-b7786000 r-xp 00000000 fe:01 45773 /usr/lib/transcode/import_null.so
b7786000-b7787000 r--p 00000000 fe:01 45773 /usr/lib/transcode/import_null.so
b7787000-b7788000 rw-p 00001000 fe:01 45773 /usr/lib/transcode/import_null.so
b7788000-b7789000 rw-p 00000000 00:00 0
b7789000-b778a000 r-xp 00000000 00:00 0 [vdso]
b778a000-b77a9000 r-xp 00000000 fe:01 1756 /lib/ld-2.14.so
b77a9000-b77aa000 r--p 0001e000 fe:01 1756 /lib/ld-2.14.so
b77aa000-b77ab000 rw-p 0001f000 fe:01 1756 /lib/ld-2.14.so
bfd41000-bfd62000 rw-p 00000000 00:00 0 [stack]
sh: line 1: 3882 Aborted execflow -n 19 transcode -H 10 -a 0 -x vob,null -i \/mnt\/rip\/LeMaitreDArmes\/vob\/001\/ -w 945,50 -c 1-144326 -L 0 -F mpeg4 -b 64,0,2 -s 2.487 --a52_drc_off -f 25.000 -Y 0,4,0,4 -B 30,15,8 -R 1 -y ffmpeg,null -o /dev/null --progress_meter 2 --progress_rate 25


Steps to reproduce (my usual procedure actually, can't try other combinations):
Using dvdrip: 2-pass encoding to ffmpeg/mpeg4 w/ frame range and w/o any filters.
This task depends upon

Closed by  Eric Belanger (Snowman)
Thursday, 12 September 2013, 20:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  transcode 1.1.7-12
Comment by Eric Belanger (Snowman) - Monday, 03 October 2011, 19:24 GMT
Is it fixed with ffmpeg 20111003-1 ?
Comment by Fabien COUTANT (fcoutant) - Tuesday, 04 October 2011, 16:38 GMT
Do you mean the version from testing ? (I'm not using it in pacman.conf, so had to download it manually along with x264.)
And no, I still get the same error.
Comment by Fabien COUTANT (fcoutant) - Sunday, 29 January 2012, 16:15 GMT
FYI
Still no fix for this.
Since several versions it now crashes right upon start of transcoding.
Current versions: glibc 2.15-4 ffmpeg 20120127-1 transcode 1.1.7-3
New extract from log message (more complete map as attachment):
...
*** glibc detected *** transcode: munmap_chunk(): invalid pointer: 0xa569a065 ***
======= Backtrace: =========
/lib/libc.so.6(+0x727a2)[0xb77337a2]
/lib/libc.so.6(+0x72e85)[0xb7733e85]
/usr/lib/transcode/export_ffmpeg.so(+0x3d4b)[0xa5693d4b]
/usr/lib/transcode/export_ffmpeg.so(+0x6477)[0xa5696477]
/usr/lib/transcode/export_ffmpeg.so(tc_export+0x477)[0xa56975a7]
transcode(tcv_export+0x62)[0x805b5e2]
transcode(tc_encoder_init+0xfa)[0x805c4da]
transcode(main+0x2b18)[0x8051ce8]
/lib/libc.so.6(__libc_start_main+0xf3)[0xb76da483]
transcode[0x80545d5]
...
sh: line 1: 2651 Aborted execflow -n 19 transcode -H 10 -a 0 -x vob,null -i \/mnt\/rip\/InsideMan\/vob\/001\/ -w 756,75 -c 1-177000 -L 0 -F mpeg4 -b 64,0,2 -s 1.268 --a52_drc_off -f 25.000 -Y 0,4,0,4 -B 32,19,8 -R 1 -y ffmpeg,null -o /dev/null --progress_meter 2 --progress_rate 25
Comment by Maik Freudenberg (mfreud) - Friday, 17 February 2012, 14:33 GMT
Just to share my findings: The new crash (not really a crash) results from some bugs in transcode. Using mpeg4 as codec, it always tries to load a ffmpeg preset 'medium' which is hardcoded in transcode. So it looks for a file $HOME/.ffmpeg/medium.ffpreset
If transcode doesn't find that file, it exits, freeing memory it hasn't yet allocated which results in the backtrace. If you create that file and leave it empty, another bug in transcode is triggered, and it segfaults. So just create $HOME/.ffmpeg/medium.ffpreset with a line starting with #, just a comment, to work around it.
The original bug, which started this thread, is still existent. Seems like an incompatibility between transcode and newer ffmpeg, but: ffmpeg-guys says: ask transcode and vice-versa. Needs some more debugging.
Workaroud: Disable glibs' mallock-check: export MALLOC_CHECK_=0 && dvdrip.

Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 25 August 2012, 20:09 GMT
upstream report?
Comment by Greg (dolby) - Monday, 15 October 2012, 08:23 GMT
Still a problem?
Comment by Fabien COUTANT (fcoutant) - Thursday, 18 October 2012, 17:43 GMT
I didn't check, since I have fallen back to using an old Arch install for video encodings.
I will try to check latest versions (assuming you mean it's corrected in ffmpeg 1.0) next weekend.
Comment by Fabien COUTANT (fcoutant) - Sunday, 11 November 2012, 20:22 GMT
Hi
Got some time to test an upgrade: transcode 1.1.7-6 with ffmpeg 1:1.0-1 (also tested 1:0.11.1-1).
Now I think it's worse, I get this instead of a stacktrace:
transcode: symbol lookup error: /usr/lib/transcode/export_ffmpeg.so: undefined symbol: avcodec_thread_init
Also, there's no log of any .ffpreset file missing, now I've got
export_ffmpeg.so warning: Error opening configuration file ./ffmpeg.cfg: No such file or directory
I don't know whether this voids the trick from Maik (didn't test before upgrade).
Comment by Maik Freudenberg (mfreud) - Wednesday, 04 September 2013, 19:22 GMT
  • Field changed: Percent Complete (100% → 0%)
Comment by Eric Belanger (Snowman) - Wednesday, 04 September 2013, 19:24 GMT
Try transcode-1.1.7-12 in [testing]. I've added new and updated ffmpeg patches which seem to include a fix for this issue. Please test and let me know if it works.

Loading...