Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26207 - [midori] crash while calling find-in-page

Attached to Project: Arch Linux
Opened by Fabien COUTANT (fcoutant) - Sunday, 02 October 2011, 18:55 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 03 October 2011, 14:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
To search in current page I start with Ctrl-F. If I use it now it crashes midori.
BTW I'm back to Ctrl-F because search-as-you-type is lost, is it upstream "feature" or packaging bug?

Additional info:
* package version(s)
midori 0.4.0-1
libwebkit 1.6.1-1
glibc 2.14-6
* config and/or log files etc.
xession errors (supposedly the error related to the crash):
midori: symbol lookup error: midori: undefined symbol: webkit_web_view_get_selected_text
* enabled extensions:
adblock, color tabs, cookie mgr, form history filler, statusbar features, tab panel

Steps to reproduce:
Try Ctrl-F even on a small page such as www.google.com
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 03 October 2011, 14:22 GMT
Reason for closing:  Fixed
Comment by Uli (Army) - Sunday, 02 October 2011, 21:15 GMT
Have you tried midori without a proxy server? I discovered, that with the newest webkit webkit-browsers crash with enabled proxy (happens with both privoxy and polipo).
Comment by Ionut Biru (wonder) - Sunday, 02 October 2011, 21:38 GMT
https://bugs.webkit.org/show_bug.cgi?id=62512

webkit_web_view_get_selected_text was dropped. report to midori bugtracker
Comment by Ionut Biru (wonder) - Monday, 03 October 2011, 08:38 GMT

Loading...