Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26199 - [Evolution] Mail Segfault since Gnome 3.2 update

Attached to Project: Arch Linux
Opened by Julien Pecqueur (jpec) - Sunday, 02 October 2011, 11:24 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 09 May 2012, 16:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since the Gnome 3.2 update, when i launch evoution mail, it segfault during the reception of mails. I have two mails accounts, they were functional before the update.

Additional info:
* package version(s)
evolution 3.2

* config and/or log files etc.


Steps to reproduce:

Launch evolution mail :

$ (jpec@Vulcain)-(~)
> evolution

** (evolution:2036): CRITICAL **: categories_icon_theme_hack: assertion `filename != NULL && *filename != '\0'' failed
(evolution:2036): Tracker-DEBUG: Tracker Evolution plugin enabled
(evolution:2036): Tracker-DEBUG: Tracker plugin creating new object...

(evolution:2036): evolution-mail-CRITICAL **: mail_store_add: assertion `store_table != NULL' failed

(evolution:2036): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `CamelOfflineStore'

(evolution:2036): camel-CRITICAL **: camel_offline_store_get_online: assertion `CAMEL_IS_OFFLINE_STORE (store)' failed

(evolution:2036): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `CamelService'

(evolution:2036): camel-CRITICAL **: camel_service_get_provider: assertion `CAMEL_IS_SERVICE (service)' failed

(evolution:2036): camel-CRITICAL **: camel_service_get_camel_url: assertion `CAMEL_IS_SERVICE (service)' failed
Erreur de segmentation
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 09 May 2012, 16:17 GMT
Reason for closing:  Fixed
Comment by Julien Pecqueur (jpec) - Sunday, 02 October 2011, 11:26 GMT
It seems related with plugins… If i launch evolution --disable-eplugin it works !
Comment by Ionut Biru (wonder) - Sunday, 02 October 2011, 11:44 GMT
please recompile evolution-data-sever, evolution and gtk3 with debug and provide better trace.


https://wiki.archlinux.org/index.php/Debug_-_Getting_Traces#One_package_settings_only
Comment by Pedro A. López-Valencia (vorbote) - Sunday, 02 October 2011, 13:49 GMT
Maybe this is an upstream failure to upgrade the dconf database? I traced the problem to the plugin path registered in the dconf database; apparently there are incomatibilities between GNOME 3.0 and 3.2. To be on the safe side and following the scorched earth doctrine, I deleted both ~/.config/dconf and ~/.cache/dconf and Evolution started working again, creating a backup first, of course. Depending on how invested you are in customizing the shell (as if!), you may want or not to do this.
Comment by Dan Andresan (forumache) - Sunday, 02 October 2011, 20:22 GMT
Same here. Pedro's solution did not help. I removed the ~/.config/dconf and ~/.cache/dconf but to no avail.

Searching the web I hit this https://bugzilla.redhat.com/show_bug.cgi?id=739046 where they blame it on "tracker".

I uninstalled gnome-documents which required tracker and... evolution started to work again.

So, it seems like the tracker plugin was the one producing the crash (strange, because my preferences said that Indexing Emails is disabled). This explains also why Julien's --disable-eplugin solution worked.
Comment by Ionut Biru (wonder) - Sunday, 02 October 2011, 20:50 GMT
even is a tracker issue, i think is it fair to try to get a proper gdb trace and forward it upstream to tracker.

you will need to recompile tracker as well
Comment by Pedro A. López-Valencia (vorbote) - Sunday, 02 October 2011, 22:06 GMT
Dan is correct. The remove dconf db hack worked for me in the morning, but this afternoon evolution started crashing when checking new mail in a freshly booted computer. I disabled evolution's tracker plugin and it is now running as stable as ever.
Comment by Julien Pecqueur (jpec) - Monday, 03 October 2011, 06:54 GMT
I uninstalled gnome-document & tracker like Dan and it woks well… So it will be OK for this week (very busy at worku) and i'll do troubleshooting next week.
Comment by Ignacio Jara (cototion) - Wednesday, 05 October 2011, 16:12 GMT
I disabled tracker plugin and runs ok...
the problem it's with the plugin, no with evolution
Comment by Ionut Biru (wonder) - Wednesday, 05 October 2011, 16:18 GMT
did anyone managed to get a trace?
Comment by Jérôme Launay (jlaunay) - Thursday, 06 October 2011, 01:36 GMT
I had the same problem and temporarily solved it by replacing extra/tracker with aur/tracker-git.
Comment by Dan Andresan (forumache) - Thursday, 06 October 2011, 16:38 GMT
Ionuț, I'll try to get a trace this weekend. This was my first week at work after vacation so I was rather busy.
Also, this will be my first trace but the documentation seems clear enough.
Comment by Dan Andresan (forumache) - Thursday, 06 October 2011, 19:48 GMT
I compile with debug information the following:
gtk3
tracker
evolution-data-server
evolution

then I logged out and back again (to make sure that the debug evolution-data-server will be in use) and typed: gdb /usr/bin/evolution.

I produced the crash but, looking at the trace log, I see nothing involving the tracker. Maybe it is not complete?
Ionuț please have a look at attached trace.log and tell me if there is more I can do.
Comment by Ionut Biru (wonder) - Wednesday, 19 October 2011, 14:13 GMT
is still still valid when using 3.2.1?
Comment by Dan Andresan (forumache) - Wednesday, 19 October 2011, 14:39 GMT
The bug disappeared when tracker was upgraded from 0.12.3 to 0.12.5, but for the wrong reasons: 0.12.5 does not contain the evolution plugin anymore, so it cannot interfere with evolution.

I'm running a stable system, Gnome is still 3.2.0 here...
Comment by Ionut Biru (wonder) - Wednesday, 19 October 2011, 14:40 GMT
ok, at least we have a stable package. gnome 3.2.1 is in testing
Comment by Dan Andresan (forumache) - Wednesday, 19 October 2011, 14:44 GMT
Yes, I've seen it in testing and I'm waiting for it to be ready ;)

evolution plugin was removed from tracker in a commit before 0.12.4 tag:
http://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/tracker&id=d1028b7c9b5d7162a537e42b24da55c317dae8be

Loading...