Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26177 - [xf86-video-intel] DDC gathered Modelines loop

Attached to Project: Arch Linux
Opened by Matej Lach (MatejLach) - Saturday, 01 October 2011, 17:12 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 20 May 2012, 08:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

I am experiencing unreasonable modeline loop using intel driver version 2.15.0-2 and that slows down X.
I don't know how to reproduce the problem on other machines, but I am using HP Pavilion DM4 1150ea.
All the relevant information can be found at https://bbs.archlinux.org/viewtopic.php?id=126371
Thank you,
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 20 May 2012, 08:39 GMT
Reason for closing:  No response
Additional comments about closing:  if still present report this upstream
Comment by Jan de Groot (JGC) - Monday, 10 October 2011, 10:34 GMT
Please test xorg-server and additional drivers from testing to see if this update fixes your issues.
Comment by Jan de Groot (JGC) - Tuesday, 11 October 2011, 21:48 GMT
  • Field changed: Status (Assigned → Waiting on Response)
2.16.0 is in extra now, please test.
Comment by Matej Lach (MatejLach) - Wednesday, 12 October 2011, 15:10 GMT
Well, after the update I am getting only 4 modelines, so it is definatelly an improvment, but it is still there.
Fresh xorg.log - http://pastebin.com/B9BBCdFp -

As it can be seen from there, the NUMBER of modelines that are printed is dramatically reduced, BUT as you can see four of them are still there and are repeating themselves in pairs.
So, something has been done, but the problem is not fixed.
(Maybe there was a side effect of another fix, so the modelines are now reduced... I'm not sure...).
Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 16:10 GMT
Status with 2.18?

Loading...