Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#26148 - [gptfdisk] compile without icu depedency

Attached to Project: Arch Linux
Opened by Anonymous Submitter - Thursday, 29 September 2011, 14:37 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 22 October 2011, 11:31 GMT
Task Type Support Request
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Low
Priority Normal
Reported Version testbuild (specify!)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

GPT fdisk needs to be included the Archiso (AIF) ISO but due to the icu dependency it is not done so. It is possible to remove ICU support from gptfdisk since it is simply required for a minor feature supported by GPT spec (GPT Partition Labels in UTF-16LE encoding). Removing ICU support does not disable "Partition Label" option in gptfdisk. In that case gptfdisk fallbacks to ASCII encoding.

The relevant info on disabling ICU usage are present in the Makefile (commented lines) http://gptfdisk.git.sourceforge.net/git/gitweb.cgi?p=gptfdisk/gptfdisk;a=blob_plain;f=Makefile;hb=HEAD and README http://gptfdisk.git.sourceforge.net/git/gitweb.cgi?p=gptfdisk/gptfdisk;a=blob_plain;f=README;hb=HEAD . Thanks in advance.

Also if possible, can this package be moved to core?
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 22 October 2011, 11:31 GMT
Reason for closing:  Won't implement
Additional comments about closing:  I don't think saving 30M on the installation images is a sufficient reason to diverge from upstream's default choices.
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 29 September 2011, 15:34 GMT
We can include gptfdisk with icu. We talk many times about CD-R/700 (only core-dual.iso will be over this at some time).
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 21 October 2011, 16:14 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Packages → Packages: Extra)
  • Field changed: Architecture (All → All)
  • Task assigned to Evangelos Foutras (foutrelis)
http://mailman.archlinux.org/pipermail/arch-releng/2011-October/002123.html [RFC] [PATCH] [configs/releng] Add gptfdisk to live enviroment.

Loading...